全部标签
目录标签

#dns

公开记录中带有此标签的全部仓库——标签来自其 GitHub 主题或软件包注册表发布的关键词。健康度量遵循与记录其余部分相同的版本化方法论。

187 条记录
标签为“dns”按健康指数排序
Go · npm
60中等健康指数
p6m7g8/p6-cdk-website-plus
P6M7G8: AWS CDK Construct that makes a Static Website R53->CF->S3 with http->https redirect and CNAMEs
Go · TypeScript★ 02026年10月18日
Apache-2.02026年10月18日 · 指标 2.10.0
Go
60中等健康指数
taihen/dns-benchmark
Recursive DNS Benchmarking Tool
Go★ 62026年9月8日
MIT2026年9月8日 · 指标 2.10.0
Go
60中等健康指数
unicrons/yatt
Yet Another Typosquatting Tool. Generates look-alike variants of a domain, resolves them over DNS, and reports which ones are registered.
Go★ 42026年9月19日
Apache-2.02026年9月19日 · 指标 2.10.0
NuGet
60中等健康指数
yswenli/SAEA
SAEA.Socket is a zero-copy, high-performance sockets network framework built on IOCP and targeting .NET Standard 2.0. The source code (Src) includes demo use cases such as P2P, SOCKS5, WebSocket client and server, message queue, RPC, Redis driver, HTTP server, MQTT, MVC, DNS, message server, and more.
C#★ 4252026年10月8日
Apache-2.02026年10月8日 · 指标 2.10.0
crates.io
59中等健康指数
hickory-dns/resolv-conf
The /etc/resolv.conf file parser in rust
Rust★ 35↓ 7.3M/月2026年9月18日
Apache-2.02026年9月18日 · 指标 2.10.0
Go
59中等健康指数
multiformats/go-multiaddr-dns
Go library and CLI tool for /dns4, /dns6, /dnsaddr multiaddr resolution
Go★ 322026年9月12日
MIT2026年9月12日 · 指标 2.10.0
Go · npm
59中等健康指数
octarq-org/octarq
Self-hosted operations backend in a single Go binary — short links, email and DNS ship as plugins, and every capability is drivable by AI agents over MCP.
Go · TypeScript★ 22026年9月15日
MIT2026年9月15日 · 指标 2.10.0
Go
59中等健康指数
shuLhan/pakakeh.go
[mirror] A collection of libraries and tools written in Go.
Go★ 482026年9月11日
BSD-3-Clause2026年9月11日 · 指标 2.10.0
Go
57中等健康指数
Tantalor93/doq-go
DoQ client library written in Golang
Go★ 62026年9月14日
MIT2026年9月14日 · 指标 2.10.0
Go
57中等健康指数
TenforwardAB/go53
A modern, API-driven authoritative DNS server built in Go. Lightning-fast, container-native, and fully zone-configurable with dynamic record handling, DNSSEC, IXFR.
Go · Shell★ 82026年9月12日
EUPL-1.22026年9月12日 · 指标 2.10.0
npm
57中等健康指数
constructive-io/dev-utils
misc web developer tools
TypeScript★ 0↓ 371.2K/月2026年9月8日
MIT2026年9月8日 · 指标 2.10.0
Go
57中等健康指数
phuslu/fastdns
Fastest DNS package for Go
Go★ 2132026年9月17日
MIT2026年9月17日 · 指标 2.10.0
crates.io
57中等健康指数
tun2proxy/socks5-impl
SOCKS5 implement library, with some useful utilities such as dns-query, socks5-server, udp-client, echo-server, etc.
Rust★ 422026年9月9日
GPL-3.02026年9月9日 · 指标 2.10.0
Go · npm
56中等健康指数
fcchbjm/AdGuardHome
AdGuard Home fork with Proxy Protocol v2 (PPv2) support for real client IP preservation behind load balancers (DoT / TCP)
TypeScript · Go · CSS★ 02026年9月14日
GPL-3.02026年9月14日 · 指标 2.10.0
Go
56中等健康指数
fcchbjm/dnsproxy
DNS proxy with DoH, DoT, DoQ, DNSCrypt and Proxy Protocol v2 support for production LB deployments
Go★ 02026年10月21日
Apache-2.02026年10月21日 · 指标 2.10.0
PyPI
56中等健康指数
m00grin/ph-intercept
A Pi-hole DNS visual dashboard. Blocking is represented by an interceptor ship destroying 'blocked query' baddies, space invaders style. Now supports AdGuard Home and Technitium!
JavaScript · Python★ 1322026年9月11日
MIT2026年9月11日 · 指标 2.10.0
npm
56中等健康指数
whisper-sec/whisper-graph-mcp
Open-source MCP server for WhisperGraph — query the internet's infrastructure & threat-intel graph (DNS, BGP, GeoIP, WHOIS) via Cypher.
TypeScript · JavaScript★ 1↓ 194/月2026年9月18日
Apache-2.02026年9月18日 · 指标 2.10.0
crates.io
54中等健康指数
jedisct1/dnssector
A DNS library for Rust.
Rust★ 23↓ 6,331/月2026年9月25日
MIT2026年9月25日 · 指标 2.10.0
npm
53中等健康指数
Kikobeats/bimi-url
Resolve BIMI DNS TXT records and fetch the brand logo URL for an email domain.
JavaScript★ 6↓ 2,163/月2026年9月18日
MIT2026年9月18日 · 指标 2.10.0
npm
53中等健康指数
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/月2026年9月13日
MIT2026年9月13日 · 指标 2.10.0
crates.io
53中等健康指数
al8n/agnostic
Agnostic is a Rust ecosystem that provides runtime-agnostic abstractions for async operations. Write your async code once and run it seamlessly with tokio, smol, or even in WebAssembly - without code changes.
Rust★ 29↓ 50.9K/月2026年10月20日
Apache-2.02026年10月20日 · 指标 2.10.0
npm
51中等健康指数
Bluscream/universal-lookup
Universal Lookup — Aggregated intelligence service for phone numbers, IPs, emails, locations, and parcels
TypeScript★ 6↓ 97/月2026年9月11日
无许可证2026年9月11日 · 指标 2.10.0
Go
51中等健康指数
alserda-nl/go-autodns
Go client for the InterNetX AutoDNS JSON API
Go★ 02026年9月12日
MIT2026年9月12日 · 指标 2.10.0
Go
51中等健康指数
servak/mping
mping is a multi-target, multi-protocol network monitoring tool
Go★ 212026年9月10日
无许可证2026年9月10日 · 指标 2.10.0
Go
50中等健康指数
aloki-alok/mailgrade
Grade any domain's email deliverability from your terminal: SPF, DKIM, DMARC, MTA-STS, DANE, reverse DNS, STARTTLS, and blocklist checks with an A-F score and exact fixes.
Go★ 02026年9月12日
MIT2026年9月12日 · 指标 2.10.0
Packagist
50中等健康指数
chieftools/dns-resolver
A recursive DNS resolver with DNSSEC validation.
PHP★ 1↓ 2,490/月2026年9月15日
Apache-2.02026年9月15日 · 指标 2.10.0
npm
48薄弱健康指数
Julusian/bonjour-service
A Bonjour/Zeroconf protocol implementation in TypeScript
TypeScript · JavaScript★ 1↓ 7,655/月2026年10月20日
MIT2026年10月20日 · 指标 2.10.0
Go · npm
48薄弱健康指数
LensDNS/DNSFleet
Unified control plane for managing AdGuard Home fleets. GitOps-style DNS configuration, observability, and centralized control for self-hosted DNS infrastructure.
TypeScript · Go★ 02026年9月14日
MIT2026年9月14日 · 指标 2.10.0
Go
48薄弱健康指数
idealo/terraform-provider-csd
Terraform provider for the common domain product
Go★ 32026年9月11日
无许可证2026年9月11日 · 指标 2.10.0
npm
48薄弱健康指数
mafintosh/dns-packet
An abstract-encoding compliant module for encoding / decoding DNS packets
JavaScript★ 217↓ 75.1M/月2026年10月20日
MIT2026年10月20日 · 指标 2.10.0