公共利益软件检验 版本化方法论

软件健康档案, 公开可查。

桥梁、电梯、食品都有公开的检验记录,支撑它们运行的软件却没有。这里就是这份记录:可维护性、工程质量、安全态势、生态采用与治理,对每一个仓库以同一标准度量。

01附带证据02结果不受付费影响03方法论版本化

申请扫描

对具有较高公共价值的仓库免费。私有及小众仓库按既定认证流程办理。

公共队列运行正常
↗
可复现的证据每一项已发布结果均链接至可检验的原始证据与方法论。
◇
独立的结果付费、赞助或供应商关系均不能改变已发布的结果。
≈
信号,而非担保结果可为审查与采购提供参考,但不能替代专家判断。
实时目录

目前已收录的全部仓库。

迄今已纳入记录的每一个仓库,可搜索、可排序,每一条都可展开完整报告及其证据。

已收录仓库
97,490
受检月下载量
649B
健康指数中位数
59 中等

类型

仓库构建的是什么——库、应用程序、宿主扩展。证据无法作答的仓库归入「未分类」。

风险警示

这类发现不计入评分,而是将评级向下调整。同时选择多项时,将显示触发其中任意一项的仓库。

清除筛选
8,286 条记录按热度排序 · 按标签浏览 · 记录统计
RubyGems
32存在风险健康指数
huacnlee/rails-settings-cached
Global settings for your Rails application.
Ruby★ 1,1222026年9月11日
自定义许可证2026年9月11日 · 指标 2.10.0
npm
27存在风险健康指数
prettymuchbryce/http-status-codes
Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.
TypeScript★ 1,120↓ 31.6M/月2026年9月17日
MIT2026年9月17日 · 指标 2.10.0
Packagist
31存在风险健康指数
renoki-co/laravel-eloquent-query-cache
Adding cache on your Laravel Eloquent queries' results is now a breeze.
PHP★ 1,119↓ 114.5K/月2026年10月22日
Apache-2.02026年10月22日 · 指标 2.10.0
NuGet
21存在风险健康指数
canton7/RestEase
Easy-to-use typesafe REST API client library for .NET Standard 1.1 and .NET Framework 4.5 and higher, which is simple and customisable. Inspired by Refit
C#★ 1,1162026年9月12日
MIT2026年9月12日 · 指标 2.10.0
npm · RubyGems
23存在风险健康指数
pid/speakingurl
Generate a slug – transliteration with a lot of options
JavaScript★ 1,116↓ 17.8M/月2026年9月23日
BSD-3-Clause2026年9月23日 · 指标 2.10.0
PyPI
19危急健康指数
PyCQA/pydocstyle
docstring style checker
Python★ 1,115↓ 4M/月2026年10月23日
MIT2026年10月23日 · 指标 2.10.0
npm
19危急健康指数
aave/aave-v3-core
This repository contains the core smart contracts of the Aave V3 protocol.
TypeScript · Solidity★ 1,115↓ 11.6K/月2026年9月16日
自定义许可证2026年9月16日 · 指标 2.10.0
PyPI
32存在风险健康指数
c4urself/bump2version
Version-bump your software with a single command
Python★ 1,115↓ 1.6M/月2026年8月27日
MIT2026年8月27日 · 指标 2.10.0
RubyGems
29存在风险健康指数
moneta-rb/moneta
a unified interface to key/value stores
Ruby★ 1,1152026年10月20日
MIT2026年10月20日 · 指标 2.10.0
Go
37薄弱健康指数
edsrzf/mmap-go
A portable mmap package for Go
Go★ 1,1132026年9月16日
BSD-3-Clause2026年9月16日 · 指标 2.10.0
npm · PyPI
34存在风险健康指数
curvefi/curve-contract
Vyper contracts used in Curve.fi exchange pools.
Python★ 1,1112026年9月12日
自定义许可证2026年9月12日 · 指标 2.10.0
PyPI
18危急健康指数
fengsp/color-thief-py
Grabs the dominant color or a representative color palette from an image. Uses Python and Pillow.
Python★ 1,109↓ 508.2K/月2026年9月17日
自定义许可证2026年9月17日 · 指标 2.10.0
npm
19危急健康指数
matrix-org/matrix-react-sdk
Matrix SDK for React Javascript
TypeScript★ 1,1092026年9月12日
Apache-2.02026年9月12日 · 指标 2.10.0
PyPI
42薄弱健康指数
flipperdevices/flipperzero-ufbt
Compact tool for building and debugging applications for Flipper Zero.
Python★ 1,106↓ 23.6K/月2026年9月13日
GPL-3.02026年9月13日 · 指标 2.10.0
Go · PyPI
32存在风险健康指数
iov-one/weave
Easy-to-use SDK to build Tendermint ABCI applications
Go★ 1,1052026年9月19日
自定义许可证2026年9月19日 · 指标 2.10.0
npm
29存在风险健康指数
d3/d3-geo
Geographic projections, spherical shapes and spherical trigonometry.
JavaScript★ 1,103↓ 117M/月2026年9月17日
自定义许可证2026年9月17日 · 指标 2.10.0
crates.io · npm
19危急健康指数
holochain/holochain-rust
DEPRECATED. The Holochain framework implemented in rust with a redux style internal state-model.
Rust★ 1,1032026年9月14日
GPL-3.02026年9月14日 · 指标 2.10.0
npm
34存在风险健康指数
istanbuljs/istanbuljs
monorepo containing the various nuts and bolts that facilitate istanbul.js test instrumentation
JavaScript★ 1,103↓ 1.5B/月2026年9月16日
无许可证2026年9月16日 · 指标 2.10.0
Go
23存在风险健康指数
peterh/liner
Pure Go line editor with history, inspired by linenoise
Go★ 1,0992026年9月23日
MIT2026年9月23日 · 指标 2.10.0
crates.io
29存在风险健康指数
BurntSushi/byteorder
Rust library for reading/writing numbers in big-endian and little-endian.
Rust★ 1,096↓ 50.8M/月2026年9月16日
Unlicense2026年9月16日 · 指标 2.10.0
PyPI
19危急健康指数
Grokzen/redis-py-cluster
Python cluster client for the official redis cluster. Redis 3.0+.
Python · Ruby★ 1,094↓ 2.8M/月2026年9月17日
MIT2026年9月17日 · 指标 2.10.0
PyPI
23存在风险健康指数
man-c/pycoingecko
Python wrapper for the CoinGecko API
Python★ 1,0922026年9月17日
MIT2026年9月17日 · 指标 2.10.0
PyPI
29存在风险健康指数
c0fec0de/anytree
Python tree data library
Python★ 1,091↓ 6.7M/月2026年8月27日
Apache-2.02026年8月27日 · 指标 2.10.0
NuGet
30存在风险健康指数
gmamaladze/globalmousekeyhook
This library allows you to tap keyboard and mouse, detect and record their activity even when an application is inactive and runs in background.
C#★ 1,0912026年9月11日
MIT2026年9月11日 · 指标 2.10.0
crates.io
19危急健康指数
dtolnay/paste
Macros for all your token pasting needs
Rust★ 1,090↓ 32.4M/月2026年9月17日
Apache-2.02026年9月17日 · 指标 2.10.0
npm
16危急健康指数
request/request-promise-native
The simplified HTTP request client 'request' with Promise support. Powered by native ES6 promises.
JavaScript★ 1,087↓ 11.2M/月2026年9月15日
ISC2026年9月15日 · 指标 2.10.0
RubyGems
20存在风险健康指数
chrisk/fakeweb
Ruby test helper for injecting fake responses to web requests
Ruby★ 1,0862026年9月12日
MIT2026年9月12日 · 指标 2.10.0
Go
23存在风险健康指数
KyleBanks/depth
Visualize Go Dependency Trees
Go★ 1,0852026年10月21日
MIT2026年10月21日 · 指标 2.10.0