Суспільно-корисна інспекція програмного забезпечення версіонована методологія

Публічний реєстр стану програмного забезпечення.

Мости, ліфти та продукти харчування мають публічні записи про свій стан. Програмне забезпечення, на якому тримаються всі троє, не має. Ось цей реєстр: підтримуваність, інженерна якість, стан безпеки, впровадження в екосистемі та врядування, виміряні однаково для кожного репозиторію.

01Докази додано02Результати не залежать від оплати03Метод версіоновано

Запит на сканування

Безкоштовно для репозиторіїв високої суспільної цінності. Приватні та нішеві репозиторії проходять задокументований шлях сертифікації.

Публічна черга працює
↗
Відтворювані доказиКожен опублікований результат посилається на доступні для перевірки джерела доказів і методологію.
◇
Незалежні результатиОплата, спонсорство чи зв'язки з постачальниками не можуть змінити опублікований результат.
≈
Сигнали, а не гарантіїРезультати допомагають у перевірці та закупівлях; вони не замінюють експертної оцінки.
Живий каталог

Реєстр станом на сьогодні.

Кожен репозиторій, внесений досі: із пошуком і впорядкуванням, а кожен запис відкриває повний звіт із доказами.

Проіндексовані репозиторії
97 490
Місячні завантаження під інспекцією
649B
Медіанний індекс здоров'я
59 Помірний

Тип

Що будує репозиторій — бібліотека, застосунок, розширення хоста. Репозиторії, чиї докази нічого не відповідають, зібрані під «Некласифіковані».

Тривожні сигнали

Знахідки, які коригують оцінку вниз, а не нараховують до неї бали. Якщо вибрати кілька, показано репозиторії, які мають хоча б один із них.

Очистити фільтри
8 286 записівУпорядковано за популярністю · перегляд за тегами · статистика реєстру
RubyGems
32У зоні ризикуіндекс здоров'я
huacnlee/rails-settings-cached
Global settings for your Rails application.
Ruby★ 1 12211 вер. 2026 р.
Власна ліцензія11 вер. 2026 р. · метрики 2.10.0
npm
27У зоні ризикуіндекс здоров'я
prettymuchbryce/http-status-codes
Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.
TypeScript★ 1 120↓ 31.6M/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
Packagist
31У зоні ризикуіндекс здоров'я
renoki-co/laravel-eloquent-query-cache
Adding cache on your Laravel Eloquent queries' results is now a breeze.
PHP★ 1 119↓ 114.5K/міс22 жовт. 2026 р.
Apache-2.022 жовт. 2026 р. · метрики 2.10.0
NuGet
21У зоні ризикуіндекс здоров'я
canton7/RestEase
Easy-to-use typesafe REST API client library for .NET Standard 1.1 and .NET Framework 4.5 and higher, which is simple and customisable. Inspired by Refit
C#★ 1 11612 вер. 2026 р.
MIT12 вер. 2026 р. · метрики 2.10.0
npm · RubyGems
23У зоні ризикуіндекс здоров'я
pid/speakingurl
Generate a slug – transliteration with a lot of options
JavaScript★ 1 116↓ 17.8M/міс23 вер. 2026 р.
BSD-3-Clause23 вер. 2026 р. · метрики 2.10.0
PyPI
19Критичнийіндекс здоров'я
PyCQA/pydocstyle
docstring style checker
Python★ 1 115↓ 4M/міс23 жовт. 2026 р.
MIT23 жовт. 2026 р. · метрики 2.10.0
npm
19Критичнийіндекс здоров'я
aave/aave-v3-core
This repository contains the core smart contracts of the Aave V3 protocol.
TypeScript · Solidity★ 1 115↓ 11.6K/міс16 вер. 2026 р.
Власна ліцензія16 вер. 2026 р. · метрики 2.10.0
PyPI
32У зоні ризикуіндекс здоров'я
c4urself/bump2version
Version-bump your software with a single command
Python★ 1 115↓ 1.6M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
RubyGems
29У зоні ризикуіндекс здоров'я
moneta-rb/moneta
a unified interface to key/value stores
Ruby★ 1 11520 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
npm
19Критичнийіндекс здоров'я
stacks-archive/blockstack-browser
The Blockstack Browser
JavaScript★ 1 11411 вер. 2026 р.
MPL-2.011 вер. 2026 р. · метрики 2.10.0
Go
37Слабкийіндекс здоров'я
edsrzf/mmap-go
A portable mmap package for Go
Go★ 1 11316 вер. 2026 р.
BSD-3-Clause16 вер. 2026 р. · метрики 2.10.0
npm · PyPI
34У зоні ризикуіндекс здоров'я
curvefi/curve-contract
Vyper contracts used in Curve.fi exchange pools.
Python★ 1 11112 вер. 2026 р.
Власна ліцензія12 вер. 2026 р. · метрики 2.10.0
PyPI
18Критичнийіндекс здоров'я
fengsp/color-thief-py
Grabs the dominant color or a representative color palette from an image. Uses Python and Pillow.
Python★ 1 109↓ 508.2K/міс17 вер. 2026 р.
Власна ліцензія17 вер. 2026 р. · метрики 2.10.0
npm
19Критичнийіндекс здоров'я
matrix-org/matrix-react-sdk
Matrix SDK for React Javascript
TypeScript★ 1 10912 вер. 2026 р.
Apache-2.012 вер. 2026 р. · метрики 2.10.0
PyPI
42Слабкийіндекс здоров'я
flipperdevices/flipperzero-ufbt
Compact tool for building and debugging applications for Flipper Zero.
Python★ 1 106↓ 23.6K/міс13 вер. 2026 р.
GPL-3.013 вер. 2026 р. · метрики 2.10.0
Go · PyPI
32У зоні ризикуіндекс здоров'я
iov-one/weave
Easy-to-use SDK to build Tendermint ABCI applications
Go★ 1 10519 вер. 2026 р.
Власна ліцензія19 вер. 2026 р. · метрики 2.10.0
npm
29У зоні ризикуіндекс здоров'я
d3/d3-geo
Geographic projections, spherical shapes and spherical trigonometry.
JavaScript★ 1 103↓ 117M/міс17 вер. 2026 р.
Власна ліцензія17 вер. 2026 р. · метрики 2.10.0
crates.io · npm
19Критичнийіндекс здоров'я
holochain/holochain-rust
DEPRECATED. The Holochain framework implemented in rust with a redux style internal state-model.
Rust★ 1 10314 вер. 2026 р.
GPL-3.014 вер. 2026 р. · метрики 2.10.0
npm
34У зоні ризикуіндекс здоров'я
istanbuljs/istanbuljs
monorepo containing the various nuts and bolts that facilitate istanbul.js test instrumentation
JavaScript★ 1 103↓ 1.5B/міс16 вер. 2026 р.
Без ліцензії16 вер. 2026 р. · метрики 2.10.0
—
19Критичнийіндекс здоров'я
kubernetes-retired/kubeadm-dind-cluster
[EOL] A Kubernetes multi-node test cluster based on kubeadm
Shell★ 1 09912 вер. 2026 р.
Apache-2.012 вер. 2026 р. · метрики 2.10.0
Go
23У зоні ризикуіндекс здоров'я
peterh/liner
Pure Go line editor with history, inspired by linenoise
Go★ 1 09923 вер. 2026 р.
MIT23 вер. 2026 р. · метрики 2.10.0
crates.io
29У зоні ризикуіндекс здоров'я
BurntSushi/byteorder
Rust library for reading/writing numbers in big-endian and little-endian.
Rust★ 1 096↓ 50.8M/міс16 вер. 2026 р.
Unlicense16 вер. 2026 р. · метрики 2.10.0
PyPI
19Критичнийіндекс здоров'я
Grokzen/redis-py-cluster
Python cluster client for the official redis cluster. Redis 3.0+.
Python · Ruby★ 1 094↓ 2.8M/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
PyPI
23У зоні ризикуіндекс здоров'я
man-c/pycoingecko
Python wrapper for the CoinGecko API
Python★ 1 09217 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
PyPI
29У зоні ризикуіндекс здоров'я
c0fec0de/anytree
Python tree data library
Python★ 1 091↓ 6.7M/міс27 серп. 2026 р.
Apache-2.027 серп. 2026 р. · метрики 2.10.0
NuGet
30У зоні ризикуіндекс здоров'я
gmamaladze/globalmousekeyhook
This library allows you to tap keyboard and mouse, detect and record their activity even when an application is inactive and runs in background.
C#★ 1 09111 вер. 2026 р.
MIT11 вер. 2026 р. · метрики 2.10.0
crates.io
19Критичнийіндекс здоров'я
dtolnay/paste
Macros for all your token pasting needs
Rust★ 1 090↓ 32.4M/міс17 вер. 2026 р.
Apache-2.017 вер. 2026 р. · метрики 2.10.0
npm
16Критичнийіндекс здоров'я
request/request-promise-native
The simplified HTTP request client 'request' with Promise support. Powered by native ES6 promises.
JavaScript★ 1 087↓ 11.2M/міс15 вер. 2026 р.
ISC15 вер. 2026 р. · метрики 2.10.0
RubyGems
20У зоні ризикуіндекс здоров'я
chrisk/fakeweb
Ruby test helper for injecting fake responses to web requests
Ruby★ 1 08612 вер. 2026 р.
MIT12 вер. 2026 р. · метрики 2.10.0
Go
23У зоні ризикуіндекс здоров'я
KyleBanks/depth
Visualize Go Dependency Trees
Go★ 1 08521 жовт. 2026 р.
MIT21 жовт. 2026 р. · метрики 2.10.0