全部标签
目录标签

#encoding

公开记录中带有此标签的全部仓库——标签来自其 GitHub 主题或软件包注册表发布的关键词。健康度量遵循与记录其余部分相同的版本化方法论。

469 条记录
标签为“encoding”按健康指数排序
crates.io
57中等健康指数
yescallop/fluent-uri-rs
A generic URI/IRI handling library compliant with RFC 3986/3987.
Rust★ 123↓ 8.5M/月2026年9月18日
MIT2026年9月18日 · 指标 2.10.0
PyPI · crates.io
57中等健康指数
ypo/flute
FLUTE (File Delivery over Unidirectional Transport) in RUST
Rust★ 44↓ 1,298/月2026年9月20日
MIT2026年9月20日 · 指标 2.10.0
npm
56中等健康指数
Borewit/text-codec
Lightweight, dependency-free TextEncoder/TextDecoder polyfill supporting UTF-8, UTF-16LE, ASCII, Latin-1, and Windows-1252 for engines like Hermes.
TypeScript★ 3↓ 82.4M/月2026年9月23日
MIT2026年9月23日 · 指标 2.10.0
crates.io
56中等健康指数
OtaK/mls-spec
This crate is a repository of MLS / RFC9420-related data structures.
Rust★ 2↓ 1,944/月2026年9月9日
Apache-2.02026年9月9日 · 指标 2.10.0
crates.io
56中等健康指数
ScaleWeather/eccodes
Unofficial high-level Rust bindings of the latest ecCodes release.
Rust★ 14↓ 4,690/月2026年10月21日
Apache-2.02026年10月21日 · 指标 2.10.0
crates.io
56中等健康指数
SpaceManiac/opus-rs
Safe Rust bindings for libopus
Rust★ 118↓ 168.3K/月2026年8月25日
Apache-2.02026年8月25日 · 指标 2.10.0
crates.io
56中等健康指数
al8n/varing
Protobuf's varint encoding/decoding for LEB128 friendly types with full const context operations supports.
Rust★ 6↓ 4,515/月2026年9月10日
Apache-2.02026年9月10日 · 指标 2.10.0
Packagist
56中等健康指数
algo26-matthias/idna-convert
Pure PHP IDNA Converter
PHP★ 71↓ 43.8K/月2026年9月24日
LGPL-2.12026年9月24日 · 指标 2.10.0
crates.io
56中等健康指数
binsnake/fARM64
ARM64 decoder and encoder
Rust★ 24↓ 18.2K/月2026年9月20日
MIT2026年9月20日 · 指标 2.10.0
crates.io
56中等健康指数
bourumir-wyngs/ply-rs
A small library to read/write ascii and binary PLY (Polygn File Format) files.
Rust★ 8↓ 180.3K/月2026年9月13日
自定义许可证2026年9月13日 · 指标 2.10.0
crates.io
56中等健康指数
bourumir-wyngs/serde-yaml-bw
Strongly typed YAML library for Rust maintained by Bourumir Wyngs
Rust★ 37↓ 55.4K/月2026年10月19日
Apache-2.02026年10月19日 · 指标 2.10.0
crates.io
56中等健康指数
cool-japan/oxiarc
OxiArc - The Oxidized Archiver Pure Rust implementation of archive and compression formats with core algorithms implemented from scratch.
Rust★ 33↓ 23.5K/月2026年10月20日
Apache-2.02026年10月20日 · 指标 2.10.0
crates.io
56中等健康指数
dtolnay/serde-untagged
Serde Visitor for deserializing untagged enums
Rust★ 71↓ 7.4M/月2026年9月17日
Apache-2.02026年9月17日 · 指标 2.10.0
crates.io
56中等健康指数
fbernier/base62
Base62 encoding/decoding library in Rust
Rust★ 35↓ 777.5K/月2026年9月15日
MIT2026年9月15日 · 指标 2.10.0
crates.io
56中等健康指数
huxi/rusty_ulid
Rust ULID (Universally Unique Lexicographically Sortable Identifier) generation and processing
Rust★ 43↓ 18.4K/月2026年9月12日
Apache-2.02026年9月12日 · 指标 2.10.0
crates.io
56中等健康指数
igankevich/human-units
Size and duration serialization library designed for configuration files and command line arguments.
Rust★ 2↓ 21.9K/月2026年10月20日
MIT2026年10月20日 · 指标 2.10.0
crates.io
56中等健康指数
jblindsay/whitebox_next_gen
Whitebox Next Generation Rust monorepo
Rust · HTML★ 98↓ 6,746/月2026年9月15日
自定义许可证2026年9月15日 · 指标 2.10.0
crates.io
56中等健康指数
macanderson/context-graph-protocol
The Context Graph Protocol is an open wire protocol for context retrieval. It treats a piece of context as a typed, budgeted, provenance-carrying, consent-gated, and conformance-verified unit of exchange called a frame — never a blob.
Rust★ 1↓ 9,376/月2026年9月18日
Apache-2.02026年9月18日 · 指标 2.10.0
crates.io
56中等健康指数
magiclen/url-escape
This library is for encoding/escaping special characters in URLs and decoding/unescaping URLs as well.
Rust★ 8↓ 97.6K/月2026年9月5日
MIT2026年9月5日 · 指标 2.10.0
crates.io
56中等健康指数
serde-rs/bytes
Wrapper types to enable optimized handling of &[u8] and Vec<u8>
Rust★ 383↓ 12.3M/月2026年9月17日
Apache-2.02026年9月17日 · 指标 2.10.0
crates.io
54中等健康指数
VoidStarKat/half-rs
Half-precision floating point types f16 and bf16 for Rust.
Rust★ 282↓ 34.8M/月2026年9月16日
Apache-2.02026年9月16日 · 指标 2.10.0
crates.io
54中等健康指数
beling/bsuccinct-rs
Rust libraries and programs focused on succinct data structures
Rust★ 173↓ 413.4K/月2026年10月19日
Apache-2.02026年10月19日 · 指标 2.10.0
crates.io
54中等健康指数
bnomei/serde_toon
Serde-compatible TOON encoder/decoder
Rust★ 0↓ 53.2K/月2026年10月3日
MIT2026年10月3日 · 指标 2.10.0
crates.io
54中等健康指数
facet-rs/facet-format
Facet format crates (JSON, TOML, YAML, Postcard, etc.)
Rust★ 12↓ 2,636/月2026年10月19日
Apache-2.02026年10月19日 · 指标 2.10.0
crates.io
54中等健康指数
harrychin/vlen
The fastest-decoding self-delimiting varint for Rust, embedded friendly to boot.
Rust★ 8↓ 2,567/月2026年8月28日
MPL-2.02026年8月28日 · 指标 2.10.0
crates.io
54中等健康指数
thunderbird/xml-struct-rs
该仓库未发布描述。
Rust★ 19↓ 6,062/月2026年10月8日
MPL-2.02026年10月8日 · 指标 2.10.0
crates.io
54中等健康指数
zs-dima/prost-protovalidate
Protobuf message validation for prost/Tonic with CEL evaluation. Full bufbuild conformance: 2854/2854.
Rust★ 25↓ 105.2K/月2026年10月20日
Apache-2.02026年10月20日 · 指标 2.10.0
crates.io
53中等健康指数
Avarok-Cybersecurity/zstd-rs
Pure-Rust no_std Zstandard (RFC 8878) compressor and decompressor; wasm32-unknown-unknown with zero imports; interoperates with C zstd
Rust★ 0↓ 2,548/月2026年10月3日
Apache-2.02026年10月3日 · 指标 2.10.0
crates.io
53中等健康指数
VoidStarKat/widestring-rs
A wide string Rust library for converting to and from wide-character strings, including UTF-16 and UTF-32 encoding.
Rust★ 102↓ 7.3M/月2026年9月17日
Apache-2.02026年9月17日 · 指标 2.10.0
crates.io
53中等健康指数
copper-project/cu-bincode
Maintained fork of the original bincode 2.x
Rust★ 7↓ 21.2K/月2026年9月15日
MIT2026年9月15日 · 指标 2.10.0