Усі теги
Тег каталогу

#encoding

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

469 записів
З тегом «encoding»Упорядковано за індексом здоров'я
crates.io
57Помірнийіндекс здоров'я
yescallop/fluent-uri-rs
A generic URI/IRI handling library compliant with RFC 3986/3987.
Rust★ 123↓ 8.5M/міс18 вер. 2026 р.
MIT18 вер. 2026 р. · метрики 2.10.0
PyPI · crates.io
57Помірнийіндекс здоров'я
ypo/flute
FLUTE (File Delivery over Unidirectional Transport) in RUST
Rust★ 44↓ 1 298/міс20 вер. 2026 р.
MIT20 вер. 2026 р. · метрики 2.10.0
npm
56Помірнийіндекс здоров'я
Borewit/text-codec
Lightweight, dependency-free TextEncoder/TextDecoder polyfill supporting UTF-8, UTF-16LE, ASCII, Latin-1, and Windows-1252 for engines like Hermes.
TypeScript★ 3↓ 82.4M/міс23 вер. 2026 р.
MIT23 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
OtaK/mls-spec
This crate is a repository of MLS / RFC9420-related data structures.
Rust★ 2↓ 1 944/міс9 вер. 2026 р.
Apache-2.09 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
ScaleWeather/eccodes
Unofficial high-level Rust bindings of the latest ecCodes release.
Rust★ 14↓ 4 690/міс21 жовт. 2026 р.
Apache-2.021 жовт. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
SpaceManiac/opus-rs
Safe Rust bindings for libopus
Rust★ 118↓ 168.3K/міс25 серп. 2026 р.
Apache-2.025 серп. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
al8n/varing
Protobuf's varint encoding/decoding for LEB128 friendly types with full const context operations supports.
Rust★ 6↓ 4 515/міс10 вер. 2026 р.
Apache-2.010 вер. 2026 р. · метрики 2.10.0
Packagist
56Помірнийіндекс здоров'я
algo26-matthias/idna-convert
Pure PHP IDNA Converter
PHP★ 71↓ 43.8K/міс24 вер. 2026 р.
LGPL-2.124 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
binsnake/fARM64
ARM64 decoder and encoder
Rust★ 24↓ 18.2K/міс20 вер. 2026 р.
MIT20 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
bourumir-wyngs/ply-rs
A small library to read/write ascii and binary PLY (Polygn File Format) files.
Rust★ 8↓ 180.3K/міс13 вер. 2026 р.
Власна ліцензія13 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
bourumir-wyngs/serde-yaml-bw
Strongly typed YAML library for Rust maintained by Bourumir Wyngs
Rust★ 37↓ 55.4K/міс19 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
cool-japan/oxiarc
OxiArc - The Oxidized Archiver Pure Rust implementation of archive and compression formats with core algorithms implemented from scratch.
Rust★ 33↓ 23.5K/міс20 жовт. 2026 р.
Apache-2.020 жовт. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
dtolnay/serde-untagged
Serde Visitor for deserializing untagged enums
Rust★ 71↓ 7.4M/міс17 вер. 2026 р.
Apache-2.017 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
fbernier/base62
Base62 encoding/decoding library in Rust
Rust★ 35↓ 777.5K/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
huxi/rusty_ulid
Rust ULID (Universally Unique Lexicographically Sortable Identifier) generation and processing
Rust★ 43↓ 18.4K/міс12 вер. 2026 р.
Apache-2.012 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
igankevich/human-units
Size and duration serialization library designed for configuration files and command line arguments.
Rust★ 2↓ 21.9K/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
jblindsay/whitebox_next_gen
Whitebox Next Generation Rust monorepo
Rust · HTML★ 98↓ 6 746/міс15 вер. 2026 р.
Власна ліцензія15 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
macanderson/context-graph-protocol
The Context Graph Protocol is an open wire protocol for context retrieval. It treats a piece of context as a typed, budgeted, provenance-carrying, consent-gated, and conformance-verified unit of exchange called a frame — never a blob.
Rust★ 1↓ 9 376/міс18 вер. 2026 р.
Apache-2.018 вер. 2026 р. · метрики 2.10.0
crates.io
56Помірнийіндекс здоров'я
serde-rs/bytes
Wrapper types to enable optimized handling of &[u8] and Vec<u8>
Rust★ 383↓ 12.3M/міс17 вер. 2026 р.
Apache-2.017 вер. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
VoidStarKat/half-rs
Half-precision floating point types f16 and bf16 for Rust.
Rust★ 282↓ 34.8M/міс16 вер. 2026 р.
Apache-2.016 вер. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
beling/bsuccinct-rs
Rust libraries and programs focused on succinct data structures
Rust★ 173↓ 413.4K/міс19 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
bnomei/serde_toon
Serde-compatible TOON encoder/decoder
Rust★ 0↓ 53.2K/міс3 жовт. 2026 р.
MIT3 жовт. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
facet-rs/facet-format
Facet format crates (JSON, TOML, YAML, Postcard, etc.)
Rust★ 12↓ 2 636/міс19 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
harrychin/vlen
The fastest-decoding self-delimiting varint for Rust, embedded friendly to boot.
Rust★ 8↓ 2 567/міс28 серп. 2026 р.
MPL-2.028 серп. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
thunderbird/xml-struct-rs
Опис репозиторію не опубліковано.
Rust★ 19↓ 6 062/міс8 жовт. 2026 р.
MPL-2.08 жовт. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
zs-dima/prost-protovalidate
Protobuf message validation for prost/Tonic with CEL evaluation. Full bufbuild conformance: 2854/2854.
Rust★ 25↓ 105.2K/міс20 жовт. 2026 р.
Apache-2.020 жовт. 2026 р. · метрики 2.10.0
crates.io
53Помірнийіндекс здоров'я
Avarok-Cybersecurity/zstd-rs
Pure-Rust no_std Zstandard (RFC 8878) compressor and decompressor; wasm32-unknown-unknown with zero imports; interoperates with C zstd
Rust★ 0↓ 2 548/міс3 жовт. 2026 р.
Apache-2.03 жовт. 2026 р. · метрики 2.10.0
crates.io
53Помірнийіндекс здоров'я
VoidStarKat/widestring-rs
A wide string Rust library for converting to and from wide-character strings, including UTF-16 and UTF-32 encoding.
Rust★ 102↓ 7.3M/міс17 вер. 2026 р.
Apache-2.017 вер. 2026 р. · метрики 2.10.0
crates.io
53Помірнийіндекс здоров'я
copper-project/cu-bincode
Maintained fork of the original bincode 2.x
Rust★ 7↓ 21.2K/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io · npm
53Помірнийіндекс здоров'я
inkandswitch/bijou
Bijective variable-length encoding for unsigned integers
HTML · Rust★ 55↓ 1 944/міс13 вер. 2026 р.
Apache-2.013 вер. 2026 р. · метрики 2.10.0