Alle Tags
Katalog-Tag

#no-dependencies

Alle Repositories im öffentlichen Register, die dieses Tag tragen — aus ihren GitHub-Topics oder den von ihren Paket-Registries veröffentlichten Schlagwörtern. Die Gesundheit wird nach derselben versionierten Methodik gemessen wie im übrigen Register.

22 Einträge
Getaggt als „no-dependencies“Geordnet nach Gesundheitsindex
npm
94AußergewöhnlichGesundheitsindex
JiHong88/suneditor
A modular WYSIWYG HTML editor with zero runtime dependencies. Everything included, enable only what you need.
JavaScript★ 2.021↓ 274.9K/Monat20. Okt. 2026
MIT20. Okt. 2026 · Metriken 2.10.0
—
91ExzellentGesundheitsindex
CLIUtils/CLI11
CLI11 is a command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface.
C++★ 4.45220. Sept. 2026
Eigene Lizenz20. Sept. 2026 · Metriken 2.10.0
—
84ExzellentGesundheitsindex
catchorg/Catch2
A modern, C++-native, test framework for unit-tests, TDD and BDD - using C++14, C++17 and later (C++11 support is in v2.x branch, and C++03 on the Catch1.x branch)
C++★ 21.5K19. Sept. 2026
BSL-1.019. Sept. 2026 · Metriken 2.10.0
npm
83ExzellentGesundheitsindex
OysteinAmundsen/toolbox
A no-dependency component library for the web
TypeScript · MDX★ 51↓ 54.7K/Monat5. Sept. 2026
MIT5. Sept. 2026 · Metriken 2.10.0
—
83ExzellentGesundheitsindex
SanderMertens/flecs
A fast entity component system (ECS) for C & C++
C★ 8.7318. Okt. 2026
Eigene Lizenz8. Okt. 2026 · Metriken 2.10.0
—
83ExzellentGesundheitsindex
skypjack/entt
Gaming meets modern C++ - a fast and reliable entity component system (ECS) and much more
C++★ 13.2K20. Okt. 2026
MIT20. Okt. 2026 · Metriken 2.10.0
Go
80ExzellentGesundheitsindex
luuuc/sense
MCP server for AI coding agents - gives Claude Code, OpenCode, Cursor, and Codex CLI structural understanding of your codebase: symbol graph, blast radius, semantic search, conventions.
Go · Python★ 3610. Sept. 2026
MIT10. Sept. 2026 · Metriken 2.10.0
—
78GutGesundheitsindex
martinus/svector
Compact SVO optimized vector for C++17 or higher
C++★ 12019. Sept. 2026
MIT19. Sept. 2026 · Metriken 2.10.0
—
75GutGesundheitsindex
Neargye/magic_enum
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
C++★ 6.17428. Aug. 2026
MIT28. Aug. 2026 · Metriken 2.10.0
Maven
75GutGesundheitsindex
ethlo/itu
An extremely fast parser and formatter of standardized date and date-times supporting RFC-3339 (ISO-8601 profile) and more.
Java★ 4119. Okt. 2026
Apache-2.019. Okt. 2026 · Metriken 2.10.0
npm
73GutGesundheitsindex
Alain00/blobatar
Keine Repository-Beschreibung veröffentlicht.
TypeScript★ 1.426↓ 1.3M/Monat3. Okt. 2026
MIT3. Okt. 2026 · Metriken 2.10.0
crates.io · Go
73GutGesundheitsindex
Michael-A-Kuykendall/muxide
Pure Rust MP4 muxer — zero deps, no FFmpeg. Feed it encoded frames, get a standards-compliant MP4. H.264, H.265, AV1, AAC, Opus.
Rust★ 75↓ 7.319/Monat20. Okt. 2026
Apache-2.020. Okt. 2026 · Metriken 2.10.0
npm
73GutGesundheitsindex
bodrovis/kliedz
Dead-simple, stateless logging utility for JavaScript and TypeScript. Pure functions. No dependencies. Just log.
TypeScript★ 1↓ 124.3K/Monat10. Okt. 2026
MIT10. Okt. 2026 · Metriken 2.10.0
—
69GutGesundheitsindex
charlesnicholson/nanoprintf
The smallest public printf implementation for its feature set.
C++ · C★ 85018. Sept. 2026
Eigene Lizenz18. Sept. 2026 · Metriken 2.10.0
Go
57MittelGesundheitsindex
slashdevops/comparator
Deep comparison and rich diffing for any Go value — text/JSON/Markdown/HTML output, RFC 6902 JSON Patch (generate & apply), custom equality, and test assertions. Zero dependencies, standard library only.
Go★ 019. Okt. 2026
Apache-2.019. Okt. 2026 · Metriken 2.10.0
npm
56MittelGesundheitsindex
AdamOusmer/bolota
Keine Repository-Beschreibung veröffentlicht.
TypeScript★ 2↓ 2.957/Monat18. Sept. 2026
MIT18. Sept. 2026 · Metriken 2.10.0
npm
56MittelGesundheitsindex
vanjs-org/van
🍦 VanJS: World's smallest reactive UI framework. Incredibly Powerful, Insanely Small - Everyone can build a useful UI app in an hour.
JavaScript · TypeScript★ 4.421↓ 11.4K/Monat28. Aug. 2026
MIT28. Aug. 2026 · Metriken 2.10.0
Go
48SchwachGesundheitsindex
ilyabrin/uniq
Generate unique ID with given length
Go★ 210. Sept. 2026
MIT10. Sept. 2026 · Metriken 2.10.0
npm
45SchwachGesundheitsindex
josias-r/boarding.js
A light-weight, no-dependency, vanilla JavaScript engine to create powerful onboardings and drive the user's focus across the page
TypeScript · HTML★ 148↓ 4.554/Monat16. Sept. 2026
MIT16. Sept. 2026 · Metriken 2.10.0
Go
44SchwachGesundheitsindex
naust-mail/naust-jmap
The Go framework for building JMAP servers. Implements RFC 8620 (Core), RFC 8621 (Mail), and more, with pluggable storage, authentication, search, and message delivery. Stdlib-only core.
Go★ 220. Sept. 2026
Apache-2.020. Sept. 2026 · Metriken 2.10.0
—
38SchwachGesundheitsindex
nonstd-lite/byte-lite
byte lite - A C++17-like byte type for C++98, C++11 and later in a single-file header-only library
C++ · Python · CMake★ 6119. Sept. 2026
BSL-1.019. Sept. 2026 · Metriken 2.10.0
npm
32GefährdetGesundheitsindex
angus-c/just
A library of dependency-free JavaScript utilities that do just one thing.
JavaScript · TypeScript★ 6.200↓ 43.7K/Monat17. Sept. 2026
MIT17. Sept. 2026 · Metriken 2.10.0