Todas las etiquetas
Etiqueta del catálogo

#no-dependencies

Todos los repositorios del registro público que llevan esta etiqueta, procedente de sus topics de GitHub o de las palabras clave que publican sus registros de paquetes. La salud se mide con la misma metodología versionada que el resto del registro.

22 registros
Con la etiqueta «no-dependencies»Ordenado por índice de salud
npm
94Excepcionalíndice de salud
JiHong88/suneditor
A modular WYSIWYG HTML editor with zero runtime dependencies. Everything included, enable only what you need.
JavaScript★ 2021↓ 274.9K/mes20 oct 2026
MIT20 oct 2026 · métricas 2.10.0
—
91Excelenteíndice de salud
CLIUtils/CLI11
CLI11 is a command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface.
C++★ 445220 sept 2026
Licencia propia20 sept 2026 · métricas 2.10.0
—
84Excelenteíndice de salud
catchorg/Catch2
A modern, C++-native, test framework for unit-tests, TDD and BDD - using C++14, C++17 and later (C++11 support is in v2.x branch, and C++03 on the Catch1.x branch)
C++★ 21.5K19 sept 2026
BSL-1.019 sept 2026 · métricas 2.10.0
npm
83Excelenteíndice de salud
OysteinAmundsen/toolbox
A no-dependency component library for the web
TypeScript · MDX★ 56↓ 25.2K/mes21 oct 2026
MIT21 oct 2026 · métricas 2.10.0
—
83Excelenteíndice de salud
SanderMertens/flecs
A fast entity component system (ECS) for C & C++
C★ 87318 oct 2026
Licencia propia8 oct 2026 · métricas 2.10.0
—
83Excelenteíndice de salud
skypjack/entt
Gaming meets modern C++ - a fast and reliable entity component system (ECS) and much more
C++★ 13.2K20 oct 2026
MIT20 oct 2026 · métricas 2.10.0
Go
80Excelenteíndice de salud
luuuc/sense
MCP server for AI coding agents - gives Claude Code, OpenCode, Cursor, and Codex CLI structural understanding of your codebase: symbol graph, blast radius, semantic search, conventions.
Go · Python★ 3610 sept 2026
MIT10 sept 2026 · métricas 2.10.0
—
78Buenoíndice de salud
martinus/svector
Compact SVO optimized vector for C++17 or higher
C++★ 12019 sept 2026
MIT19 sept 2026 · métricas 2.10.0
—
75Buenoíndice de salud
Neargye/magic_enum
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
C++★ 617428 ago 2026
MIT28 ago 2026 · métricas 2.10.0
Maven
75Buenoíndice de salud
ethlo/itu
An extremely fast parser and formatter of standardized date and date-times supporting RFC-3339 (ISO-8601 profile) and more.
Java★ 4119 oct 2026
Apache-2.019 oct 2026 · métricas 2.10.0
npm
73Buenoíndice de salud
Alain00/blobatar
El repositorio no publica descripción.
TypeScript★ 1426↓ 1.3M/mes3 oct 2026
MIT3 oct 2026 · métricas 2.10.0
crates.io · Go
73Buenoíndice de salud
Michael-A-Kuykendall/muxide
Pure Rust MP4 muxer — zero deps, no FFmpeg. Feed it encoded frames, get a standards-compliant MP4. H.264, H.265, AV1, AAC, Opus.
Rust★ 75↓ 7319/mes20 oct 2026
Apache-2.020 oct 2026 · métricas 2.10.0
npm
73Buenoíndice de salud
bodrovis/kliedz
Dead-simple, stateless logging utility for JavaScript and TypeScript. Pure functions. No dependencies. Just log.
TypeScript★ 1↓ 124.3K/mes10 oct 2026
MIT10 oct 2026 · métricas 2.10.0
—
69Buenoíndice de salud
charlesnicholson/nanoprintf
The smallest public printf implementation for its feature set.
C++ · C★ 85018 sept 2026
Licencia propia18 sept 2026 · métricas 2.10.0
Go
57Moderadoíndice de salud
slashdevops/comparator
Deep comparison and rich diffing for any Go value — text/JSON/Markdown/HTML output, RFC 6902 JSON Patch (generate & apply), custom equality, and test assertions. Zero dependencies, standard library only.
Go★ 019 oct 2026
Apache-2.019 oct 2026 · métricas 2.10.0
npm
56Moderadoíndice de salud
AdamOusmer/bolota
El repositorio no publica descripción.
TypeScript★ 2↓ 2957/mes18 sept 2026
MIT18 sept 2026 · métricas 2.10.0
npm
56Moderadoíndice de salud
vanjs-org/van
🍦 VanJS: World's smallest reactive UI framework. Incredibly Powerful, Insanely Small - Everyone can build a useful UI app in an hour.
JavaScript · TypeScript★ 4421↓ 11.4K/mes28 ago 2026
MIT28 ago 2026 · métricas 2.10.0
Go
48Débilíndice de salud
ilyabrin/uniq
Generate unique ID with given length
Go★ 210 sept 2026
MIT10 sept 2026 · métricas 2.10.0
npm
45Débilíndice de salud
josias-r/boarding.js
A light-weight, no-dependency, vanilla JavaScript engine to create powerful onboardings and drive the user's focus across the page
TypeScript · HTML★ 148↓ 4554/mes16 sept 2026
MIT16 sept 2026 · métricas 2.10.0
Go
44Débilíndice de salud
naust-mail/naust-jmap
The Go framework for building JMAP servers. Implements RFC 8620 (Core), RFC 8621 (Mail), and more, with pluggable storage, authentication, search, and message delivery. Stdlib-only core.
Go★ 220 sept 2026
Apache-2.020 sept 2026 · métricas 2.10.0
—
38Débilíndice de salud
nonstd-lite/byte-lite
byte lite - A C++17-like byte type for C++98, C++11 and later in a single-file header-only library
C++ · Python · CMake★ 6119 sept 2026
BSL-1.019 sept 2026 · métricas 2.10.0
npm
32En riesgoíndice de salud
angus-c/just
A library of dependency-free JavaScript utilities that do just one thing.
JavaScript · TypeScript★ 6200↓ 43.7K/mes17 sept 2026
MIT17 sept 2026 · métricas 2.10.0