Усі теги
Тег каталогу

#no-dependencies

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

22 записи
З тегом «no-dependencies»Упорядковано за індексом здоров'я
npm
94Винятковийіндекс здоров'я
JiHong88/suneditor
A modular WYSIWYG HTML editor with zero runtime dependencies. Everything included, enable only what you need.
JavaScript★ 2 021↓ 274.9K/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
—
91Відміннийіндекс здоров'я
CLIUtils/CLI11
CLI11 is a command line parser for C++11 and beyond that provides a rich feature set with a simple and intuitive interface.
C++★ 4 45220 вер. 2026 р.
Власна ліцензія20 вер. 2026 р. · метрики 2.10.0
—
84Відміннийіндекс здоров'я
catchorg/Catch2
A modern, C++-native, test framework for unit-tests, TDD and BDD - using C++14, C++17 and later (C++11 support is in v2.x branch, and C++03 on the Catch1.x branch)
C++★ 21.5K19 вер. 2026 р.
BSL-1.019 вер. 2026 р. · метрики 2.10.0
npm
83Відміннийіндекс здоров'я
OysteinAmundsen/toolbox
A no-dependency component library for the web
TypeScript · MDX★ 56↓ 25.2K/міс21 жовт. 2026 р.
MIT21 жовт. 2026 р. · метрики 2.10.0
—
83Відміннийіндекс здоров'я
SanderMertens/flecs
A fast entity component system (ECS) for C & C++
C★ 8 7318 жовт. 2026 р.
Власна ліцензія8 жовт. 2026 р. · метрики 2.10.0
—
83Відміннийіндекс здоров'я
skypjack/entt
Gaming meets modern C++ - a fast and reliable entity component system (ECS) and much more
C++★ 13.2K20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
Go
80Відміннийіндекс здоров'я
luuuc/sense
MCP server for AI coding agents - gives Claude Code, OpenCode, Cursor, and Codex CLI structural understanding of your codebase: symbol graph, blast radius, semantic search, conventions.
Go · Python★ 3610 вер. 2026 р.
MIT10 вер. 2026 р. · метрики 2.10.0
—
78Добрийіндекс здоров'я
martinus/svector
Compact SVO optimized vector for C++17 or higher
C++★ 12019 вер. 2026 р.
MIT19 вер. 2026 р. · метрики 2.10.0
—
75Добрийіндекс здоров'я
Neargye/magic_enum
Static reflection for enums (to string, from string, iteration) for modern C++, work with any enum type without any macro or boilerplate code
C++★ 6 17428 серп. 2026 р.
MIT28 серп. 2026 р. · метрики 2.10.0
Maven
75Добрийіндекс здоров'я
ethlo/itu
An extremely fast parser and formatter of standardized date and date-times supporting RFC-3339 (ISO-8601 profile) and more.
Java★ 4119 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
npm
73Добрийіндекс здоров'я
Alain00/blobatar
Опис репозиторію не опубліковано.
TypeScript★ 1 426↓ 1.3M/міс3 жовт. 2026 р.
MIT3 жовт. 2026 р. · метрики 2.10.0
crates.io · Go
73Добрийіндекс здоров'я
Michael-A-Kuykendall/muxide
Pure Rust MP4 muxer — zero deps, no FFmpeg. Feed it encoded frames, get a standards-compliant MP4. H.264, H.265, AV1, AAC, Opus.
Rust★ 75↓ 7 319/міс20 жовт. 2026 р.
Apache-2.020 жовт. 2026 р. · метрики 2.10.0
npm
73Добрийіндекс здоров'я
bodrovis/kliedz
Dead-simple, stateless logging utility for JavaScript and TypeScript. Pure functions. No dependencies. Just log.
TypeScript★ 1↓ 124.3K/міс10 жовт. 2026 р.
MIT10 жовт. 2026 р. · метрики 2.10.0
—
69Добрийіндекс здоров'я
charlesnicholson/nanoprintf
The smallest public printf implementation for its feature set.
C++ · C★ 85018 вер. 2026 р.
Власна ліцензія18 вер. 2026 р. · метрики 2.10.0
Go
57Помірнийіндекс здоров'я
slashdevops/comparator
Deep comparison and rich diffing for any Go value — text/JSON/Markdown/HTML output, RFC 6902 JSON Patch (generate & apply), custom equality, and test assertions. Zero dependencies, standard library only.
Go★ 019 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
npm
56Помірнийіндекс здоров'я
AdamOusmer/bolota
Опис репозиторію не опубліковано.
TypeScript★ 2↓ 2 957/міс18 вер. 2026 р.
MIT18 вер. 2026 р. · метрики 2.10.0
npm
56Помірнийіндекс здоров'я
vanjs-org/van
🍦 VanJS: World's smallest reactive UI framework. Incredibly Powerful, Insanely Small - Everyone can build a useful UI app in an hour.
JavaScript · TypeScript★ 4 421↓ 11.4K/міс28 серп. 2026 р.
MIT28 серп. 2026 р. · метрики 2.10.0
Go
48Слабкийіндекс здоров'я
ilyabrin/uniq
Generate unique ID with given length
Go★ 210 вер. 2026 р.
MIT10 вер. 2026 р. · метрики 2.10.0
npm
45Слабкийіндекс здоров'я
josias-r/boarding.js
A light-weight, no-dependency, vanilla JavaScript engine to create powerful onboardings and drive the user's focus across the page
TypeScript · HTML★ 148↓ 4 554/міс16 вер. 2026 р.
MIT16 вер. 2026 р. · метрики 2.10.0
Go
44Слабкийіндекс здоров'я
naust-mail/naust-jmap
The Go framework for building JMAP servers. Implements RFC 8620 (Core), RFC 8621 (Mail), and more, with pluggable storage, authentication, search, and message delivery. Stdlib-only core.
Go★ 220 вер. 2026 р.
Apache-2.020 вер. 2026 р. · метрики 2.10.0
—
38Слабкийіндекс здоров'я
nonstd-lite/byte-lite
byte lite - A C++17-like byte type for C++98, C++11 and later in a single-file header-only library
C++ · Python · CMake★ 6119 вер. 2026 р.
BSL-1.019 вер. 2026 р. · метрики 2.10.0
npm
32У зоні ризикуіндекс здоров'я
angus-c/just
A library of dependency-free JavaScript utilities that do just one thing.
JavaScript · TypeScript★ 6 200↓ 43.7K/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0