Alle Tags
Katalog-Tag

#hostname

Alle Repositories im öffentlichen Register, die dieses Tag tragen — aus ihren GitHub-Topics oder den von ihren Paket-Registries veröffentlichten Schlagwörtern. Die Gesundheit wird nach derselben versionierten Methodik gemessen wie im übrigen Register.

12 Einträge
Getaggt als „hostname“Geordnet nach Gesundheitsindex
crates.io
87ExzellentGesundheitsindex
ardaku/whoami
Rust library for getting information about the current user and environment.
Rust★ 264↓ 19.6M/Monat17. Sept. 2026
Apache-2.017. Sept. 2026 · Metriken 2.10.0
npm
83ExzellentGesundheitsindex
remusao/tldts
JavaScript Library to extract domains, subdomains and public suffixes from complex URIs.
TypeScript★ 764↓ 602M/Monat11. Sept. 2026
MIT11. Sept. 2026 · Metriken 2.10.0
crates.io
77GutGesundheitsindex
djc/hostname
Cross-platform hostname functions in Rust
Rust★ 79↓ 13.3M/Monat17. Sept. 2026
MIT17. Sept. 2026 · Metriken 2.10.0
Packagist
73GutGesundheitsindex
thephpleague/uri
[READ-ONLY] URI manipulation Library
PHP★ 1.131↓ 19.4M/Monat20. Okt. 2026
MIT20. Okt. 2026 · Metriken 2.10.0
npm
71GutGesundheitsindex
ni-c/mcp-internal-hosts
Is this host only reachable from where you stand? Classifies loopback, link-local and cloud-metadata hostnames — numerically, in every spelling
TypeScript★ 0↓ 3.276/Monat9. Okt. 2026
MIT9. Okt. 2026 · Metriken 2.10.0
npm
65GutGesundheitsindex
Kikobeats/is-local-address
Statically check whether a hostname or IP is a local, loopback, private, or link-local address.
JavaScript★ 17↓ 41K/Monat15. Sept. 2026
MIT15. Sept. 2026 · Metriken 2.10.0
crates.io
65GutGesundheitsindex
al8n/hostaddr
Extended types for working with net in Rust.
Rust★ 3↓ 7.920/Monat7. Okt. 2026
Apache-2.07. Okt. 2026 · Metriken 2.10.0
npm
62MittelGesundheitsindex
microlinkhq/ping-url
Fast DNS resolution for URLs with short-lived caching via Keyv-compatible stores.
JavaScript★ 10↓ 1.967/Monat10. Sept. 2026
MIT10. Sept. 2026 · Metriken 2.10.0
Packagist
59MittelGesundheitsindex
thephpleague/uri-interfaces
[READ-ONLY] League URI common
PHP★ 543↓ 14M/Monat27. Aug. 2026
MIT27. Aug. 2026 · Metriken 2.10.0
npm
53MittelGesundheitsindex
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/Monat13. Sept. 2026
MIT13. Sept. 2026 · Metriken 2.10.0
PyPI
25GefährdetGesundheitsindex
ypcrts/fqdn
RFC-compliant FQDN validation and manipulation for Python.
Python★ 379. Sept. 2026
MPL-2.09. Sept. 2026 · Metriken 2.10.0
Go
24GefährdetGesundheitsindex
zignd/docker-hoster
A lightweight Go utility that automatically manages /etc/hosts entries for Docker containers. It monitors Docker events and dynamically updates the hosts file with container network information, making it easy to access containers by hostname.
Go★ 219. Sept. 2026
MIT19. Sept. 2026 · Metriken 2.10.0