Todas las etiquetas
Etiqueta del catálogo

#hostname

Todos los repositorios del registro público que llevan esta etiqueta, procedente de sus topics de GitHub o de las palabras clave que publican sus registros de paquetes. La salud se mide con la misma metodología versionada que el resto del registro.

12 registros
Con la etiqueta «hostname»Ordenado por índice de salud
crates.io
87Excelenteíndice de salud
ardaku/whoami
Rust library for getting information about the current user and environment.
Rust★ 264↓ 19.6M/mes17 sept 2026
Apache-2.017 sept 2026 · métricas 2.10.0
npm
83Excelenteíndice de salud
remusao/tldts
JavaScript Library to extract domains, subdomains and public suffixes from complex URIs.
TypeScript★ 764↓ 602M/mes11 sept 2026
MIT11 sept 2026 · métricas 2.10.0
crates.io
77Buenoíndice de salud
djc/hostname
Cross-platform hostname functions in Rust
Rust★ 79↓ 13.3M/mes17 sept 2026
MIT17 sept 2026 · métricas 2.10.0
Packagist
73Buenoíndice de salud
thephpleague/uri
[READ-ONLY] URI manipulation Library
PHP★ 1131↓ 19.4M/mes20 oct 2026
MIT20 oct 2026 · métricas 2.10.0
npm
71Buenoíndice de salud
ni-c/mcp-internal-hosts
Is this host only reachable from where you stand? Classifies loopback, link-local and cloud-metadata hostnames — numerically, in every spelling
TypeScript★ 0↓ 3276/mes9 oct 2026
MIT9 oct 2026 · métricas 2.10.0
npm
65Buenoíndice de salud
Kikobeats/is-local-address
Statically check whether a hostname or IP is a local, loopback, private, or link-local address.
JavaScript★ 17↓ 41K/mes15 sept 2026
MIT15 sept 2026 · métricas 2.10.0
crates.io
65Buenoíndice de salud
al8n/hostaddr
Extended types for working with net in Rust.
Rust★ 3↓ 7920/mes7 oct 2026
Apache-2.07 oct 2026 · métricas 2.10.0
npm
62Moderadoíndice de salud
microlinkhq/ping-url
Fast DNS resolution for URLs with short-lived caching via Keyv-compatible stores.
JavaScript★ 10↓ 1967/mes10 sept 2026
MIT10 sept 2026 · métricas 2.10.0
Packagist
59Moderadoíndice de salud
thephpleague/uri-interfaces
[READ-ONLY] League URI common
PHP★ 543↓ 14M/mes27 ago 2026
MIT27 ago 2026 · métricas 2.10.0
npm
53Moderadoíndice de salud
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/mes13 sept 2026
MIT13 sept 2026 · métricas 2.10.0
PyPI
25En riesgoíndice de salud
ypcrts/fqdn
RFC-compliant FQDN validation and manipulation for Python.
Python★ 379 sept 2026
MPL-2.09 sept 2026 · métricas 2.10.0
Go
24En riesgoíndice de salud
zignd/docker-hoster
A lightweight Go utility that automatically manages /etc/hosts entries for Docker containers. It monitors Docker events and dynamically updates the hosts file with container network information, making it easy to access containers by hostname.
Go★ 219 sept 2026
MIT19 sept 2026 · métricas 2.10.0