Усі теги
Тег каталогу

#hostname

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

12 записів
З тегом «hostname»Упорядковано за індексом здоров'я
crates.io
87Відміннийіндекс здоров'я
ardaku/whoami
Rust library for getting information about the current user and environment.
Rust★ 264↓ 19.6M/міс17 вер. 2026 р.
Apache-2.017 вер. 2026 р. · метрики 2.10.0
npm
83Відміннийіндекс здоров'я
remusao/tldts
JavaScript Library to extract domains, subdomains and public suffixes from complex URIs.
TypeScript★ 764↓ 602M/міс11 вер. 2026 р.
MIT11 вер. 2026 р. · метрики 2.10.0
crates.io
77Добрийіндекс здоров'я
djc/hostname
Cross-platform hostname functions in Rust
Rust★ 79↓ 13.3M/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
Packagist
73Добрийіндекс здоров'я
thephpleague/uri
[READ-ONLY] URI manipulation Library
PHP★ 1 131↓ 19.4M/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
npm
71Добрийіндекс здоров'я
ni-c/mcp-internal-hosts
Is this host only reachable from where you stand? Classifies loopback, link-local and cloud-metadata hostnames — numerically, in every spelling
TypeScript★ 0↓ 3 276/міс9 жовт. 2026 р.
MIT9 жовт. 2026 р. · метрики 2.10.0
npm
65Добрийіндекс здоров'я
Kikobeats/is-local-address
Statically check whether a hostname or IP is a local, loopback, private, or link-local address.
JavaScript★ 17↓ 41K/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io
65Добрийіндекс здоров'я
al8n/hostaddr
Extended types for working with net in Rust.
Rust★ 3↓ 7 920/міс7 жовт. 2026 р.
Apache-2.07 жовт. 2026 р. · метрики 2.10.0
npm
62Помірнийіндекс здоров'я
microlinkhq/ping-url
Fast DNS resolution for URLs with short-lived caching via Keyv-compatible stores.
JavaScript★ 10↓ 1 967/міс10 вер. 2026 р.
MIT10 вер. 2026 р. · метрики 2.10.0
Packagist
59Помірнийіндекс здоров'я
thephpleague/uri-interfaces
[READ-ONLY] League URI common
PHP★ 543↓ 14M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
npm
53Помірнийіндекс здоров'я
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/міс13 вер. 2026 р.
MIT13 вер. 2026 р. · метрики 2.10.0
PyPI
25У зоні ризикуіндекс здоров'я
ypcrts/fqdn
RFC-compliant FQDN validation and manipulation for Python.
Python★ 379 вер. 2026 р.
MPL-2.09 вер. 2026 р. · метрики 2.10.0
Go
24У зоні ризикуіндекс здоров'я
zignd/docker-hoster
A lightweight Go utility that automatically manages /etc/hosts entries for Docker containers. It monitors Docker events and dynamically updates the hosts file with container network information, making it easy to access containers by hostname.
Go★ 219 вер. 2026 р.
MIT19 вер. 2026 р. · метрики 2.10.0