全部标签
目录标签

#hostname

公开记录中带有此标签的全部仓库——标签来自其 GitHub 主题或软件包注册表发布的关键词。健康度量遵循与记录其余部分相同的版本化方法论。

12 条记录
标签为“hostname”按健康指数排序
crates.io
87优秀健康指数
ardaku/whoami
Rust library for getting information about the current user and environment.
Rust★ 264↓ 19.6M/月2026年9月17日
Apache-2.02026年9月17日 · 指标 2.10.0
npm
83优秀健康指数
remusao/tldts
JavaScript Library to extract domains, subdomains and public suffixes from complex URIs.
TypeScript★ 764↓ 602M/月2026年9月11日
MIT2026年9月11日 · 指标 2.10.0
crates.io
77良好健康指数
djc/hostname
Cross-platform hostname functions in Rust
Rust★ 79↓ 13.3M/月2026年9月17日
MIT2026年9月17日 · 指标 2.10.0
Packagist
73良好健康指数
thephpleague/uri
[READ-ONLY] URI manipulation Library
PHP★ 1,131↓ 19.4M/月2026年10月20日
MIT2026年10月20日 · 指标 2.10.0
npm
71良好健康指数
ni-c/mcp-internal-hosts
Is this host only reachable from where you stand? Classifies loopback, link-local and cloud-metadata hostnames — numerically, in every spelling
TypeScript★ 0↓ 3,276/月2026年10月9日
MIT2026年10月9日 · 指标 2.10.0
npm
65良好健康指数
Kikobeats/is-local-address
Statically check whether a hostname or IP is a local, loopback, private, or link-local address.
JavaScript★ 17↓ 41K/月2026年9月15日
MIT2026年9月15日 · 指标 2.10.0
crates.io
65良好健康指数
al8n/hostaddr
Extended types for working with net in Rust.
Rust★ 3↓ 7,920/月2026年10月7日
Apache-2.02026年10月7日 · 指标 2.10.0
npm
62中等健康指数
microlinkhq/ping-url
Fast DNS resolution for URLs with short-lived caching via Keyv-compatible stores.
JavaScript★ 10↓ 1,967/月2026年9月10日
MIT2026年9月10日 · 指标 2.10.0
Packagist
59中等健康指数
thephpleague/uri-interfaces
[READ-ONLY] League URI common
PHP★ 543↓ 14M/月2026年8月27日
MIT2026年8月27日 · 指标 2.10.0
npm
53中等健康指数
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/月2026年9月13日
MIT2026年9月13日 · 指标 2.10.0
PyPI
25存在风险健康指数
ypcrts/fqdn
RFC-compliant FQDN validation and manipulation for Python.
Python★ 372026年9月9日
MPL-2.02026年9月9日 · 指标 2.10.0
Go
24存在风险健康指数
zignd/docker-hoster
A lightweight Go utility that automatically manages /etc/hosts entries for Docker containers. It monitors Docker events and dynamically updates the hosts file with container network information, making it easy to access containers by hostname.
Go★ 22026年9月19日
MIT2026年9月19日 · 指标 2.10.0