TypeScript★ 27↓ 36/moAug 23, 2026
JavaScript★ 31Sep 13, 2026

Shyam20001/rsjsBrahma-Firelight — A Rust-powered, memory-safe Node.js web framework built on Tokio + Hyper.
JavaScript★ 70↓ 181/moSep 13, 2026

jonschlinkert/gray-matterSmarter YAML front matter parser, used by metalsmith, Gatsby, Netlify, Assemble, mapbox-gl, phenomic, vuejs vitepress, TinaCMS, Shopify Polaris, Ant Design, Astro, hashicorp, garden, slidev, saber, sourcegraph, and many others. Simple to use, and battle tested. Parses YAML by default but can also parse JSON Front Matter, Coffee Front Matter, TOML Front Matter, and has support for custom parsers. Please follow gray-matter's author: https://github.com/jonschlinkert
JavaScript★ 4,488↓ 33.7M/moSep 17, 2026

micromatch/nanomatchFast, minimal glob matcher for node.js. Similar to micromatch, minimatch and multimatch, but without support for extended globs (extglobs), posix brackets or braces, and with complete Bash 4.3 wildcard support: ("*", "**", and "?").
JavaScript★ 97↓ 34.8M/moSep 15, 2026
CoffeeScript★ 2,374↓ 18.5M/moSep 17, 2026

wxyz-abcd/node-haxballThe most powerful and lightweight API that allows you to develop your original Haxball(www.haxball.com) host, client, and standalone applications both on node.js and browser environments and also includes every possible hack and functionality that you can imagine.
JavaScript★ 63↓ 1,559/moSep 13, 2026
npm · Packagist29At Riskhealth index

Blackbytespace/sugarA toolkit that gives you access to lots of of cool and useful Node and TS functions/classes like "querySelectorLive", "getFreePort", etc...
TypeScript★ 1↓ 2,838/moSep 18, 2026
TypeScript · JavaScript★ 71↓ 4,091/moSep 18, 2026

OpenFlun/webauthn-server这是一个专为 Node.js 环境设计的 WebAuthn(含 Passkeys)服务端工具库,提供简洁的 TypeScript 实现,并内置对证书、密钥及 CBOR 编码的完整处理能力,适用于构建 FIDO2/Passkey 身份验证后端
JavaScript★ 0↓ 345/moSep 17, 2026
crates.io29At Riskhealth index
Rust★ 0Sep 11, 2026
JavaScript★ 574↓ 21.5M/moSep 15, 2026
JavaScript★ 112↓ 470M/moSep 16, 2026
JavaScript★ 276↓ 58.4M/moSep 15, 2026
JavaScript★ 30Sep 15, 2026
JavaScript★ 26↓ 4,494/moSep 20, 2026
JavaScript★ 23↓ 14.8K/moAug 28, 2026
JavaScript★ 7↓ 176M/moSep 23, 2026

fent/randexp.jsCreate random strings that match a given regular expression.
JavaScript★ 1,865↓ 41.7M/moSep 17, 2026
JavaScript★ 28↓ 35.1M/moSep 15, 2026
JavaScript★ 75↓ 117M/moOct 20, 2026
JavaScript★ 58↓ 37.1M/moSep 15, 2026
TypeScript★ 774↓ 99.9M/moSep 16, 2026
JavaScript★ 24Sep 13, 2026
JavaScript★ 65↓ 218M/moSep 15, 2026
TypeScript★ 9↓ 3,122/moOct 21, 2026
TypeScript★ 0↓ 39.5K/moSep 8, 2026

kach/nearley📜🔜🌲 Simple, fast, powerful parser toolkit for JavaScript.
JavaScript · HTML★ 3,742Sep 17, 2026

micromatch/to-regex-rangePass two numbers, get a regex-compatible source string for matching ranges. Fast compiler, optimized regex, and validated against more than 2.78 million test assertions. Useful for creating regular expressions to validate numbers, ranges, years, etc.
JavaScript★ 173↓ 601M/moSep 16, 2026

prettymuchbryce/http-status-codesConstants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.
TypeScript★ 1,120↓ 31.6M/moSep 17, 2026