Усі теги
Тег каталогу

#hmac

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

45 записів
З тегом «hmac»Упорядковано за індексом здоров'я
npm
89Відміннийіндекс здоров'я
yeojz/otplib
One Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2 292↓ 51.3M/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
Packagist · Go
87Відміннийіндекс здоров'я
standard-webhooks/standard-webhooks
The Standard Webhooks specification
Java · Elixir · C#★ 1 741↓ 423.5K/міс8 вер. 2026 р.
Apache-2.08 вер. 2026 р. · метрики 2.10.0
npm · Go · PyPI
84Відміннийіндекс здоров'я
primitivedotdev/sdks
Official Node.js, Python, and Go SDKs plus the primitive CLI for Primitive — email infrastructure for AI agents. Generated from the OpenAPI spec.
TypeScript · Python★ 7↓ 30.7K/міс12 вер. 2026 р.
MIT12 вер. 2026 р. · метрики 2.10.0
npm · Go
83Відміннийіндекс здоров'я
kibertoad/cat-factory
Software development agent management platform
TypeScript★ 10↓ 19.9K/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
Packagist · PyPI
81Відміннийіндекс здоров'я
infocyph/OTP
Simple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/міс7 вер. 2026 р.
MIT7 вер. 2026 р. · метрики 2.10.0
npm
80Відміннийіндекс здоров'я
JiangJie/minigame-std
Cross-platform standard library for WeChat minigame and web browsers with unified APIs for crypto, fs, fetch, storage, and more.
TypeScript★ 3↓ 3 438/міс9 вер. 2026 р.
MIT9 вер. 2026 р. · метрики 2.10.0
NuGet
80Відміннийіндекс здоров'я
NetDevPack/Security.Jwt
Jwt Manager. Set of components to deal with Jwt Stuff. Automate your key rotating, add support for jwks_uri. Store your cryptography keys in a secure place.
C#★ 2971 жовт. 2026 р.
MIT1 жовт. 2026 р. · метрики 2.10.0
npm
77Добрийіндекс здоров'я
JosephDoUrden/webhook-hmac-kit
Webhook signing that hashes the bytes. Stripe-style and Standard Webhooks formats, zero runtime dependencies.
TypeScript★ 1↓ 6 265/міс14 жовт. 2026 р.
MIT14 жовт. 2026 р. · метрики 2.10.0
npm
77Добрийіндекс здоров'я
digitalbazaar/forge
A native implementation of TLS in Javascript and tools to write crypto-based and network-heavy webapps
JavaScript★ 5 332↓ 144M/міс17 вер. 2026 р.
Власна ліцензія17 вер. 2026 р. · метрики 2.10.0
npm
73Добрийіндекс здоров'я
BlackUnicornSecurity/bonklm
BonkLM - LLM Security Guardrails with Interactive Setup Wizard
TypeScript★ 5↓ 7 724/міс18 вер. 2026 р.
Apache-2.018 вер. 2026 р. · метрики 2.10.0
npm
73Добрийіндекс здоров'я
paulmillr/noble-hashes
Audited & minimal JS implementation of hash functions, MACs and KDFs.
TypeScript★ 932↓ 385M/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
npm
71Добрийіндекс здоров'я
krovacloud/krova-node
Monorepo for the Krova Cloud JS/TS packages — SDK, CLI, MCP, webhook verifier, n8n node.
TypeScript★ 0↓ 6 150/міс13 вер. 2026 р.
MIT13 вер. 2026 р. · метрики 2.10.0
NuGet
69Добрийіндекс здоров'я
HMBSbige/CryptoBase
A fast crypto library for .NET
C#★ 2515 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
npm
69Добрийіндекс здоров'я
putervision/WebCrypt
Zero-dependency Web Crypto suite & Model Context Protocol (MCP) server for AES-256-GCM, RSA-4096, and AI agent security.
JavaScript★ 28↓ 18.7K/міс21 вер. 2026 р.
MIT21 вер. 2026 р. · метрики 2.10.0
PyPI · npm
67Добрийіндекс здоров'я
ginkida/sallyport
A security-first bridge between Claude Code (MCP) and Chrome — HMAC pairing, domain allowlist, per-domain evaluate opt-in.
TypeScript · Python★ 10↓ 576/міс10 вер. 2026 р.
MIT10 вер. 2026 р. · метрики 2.10.0
npm
67Добрийіндекс здоров'я
junkurihara/jscu
JavaScript cryptographic utilities for crypto-suite compatibility including PEM/X509/JWK converter.
TypeScript · JavaScript★ 162↓ 462.7K/міс9 вер. 2026 р.
MIT9 вер. 2026 р. · метрики 2.10.0
Maven · PyPI
65Добрийіндекс здоров'я
AindriuB/data-prism
Data Prism is an open-source privacy layer for Java/Spring teams putting LLM agents or MCP clients in front of internal APIs holding customer data. It pseudonymises personal data per privacy scope, refuses anything unclassified, and can keep a hash-chained audit trail.
Java★ 119 жовт. 2026 р.
Apache-2.019 жовт. 2026 р. · метрики 2.10.0
npm
65Добрийіндекс здоров'я
emn178/js-sha256
A simple SHA-256 / SHA-224 hash function for JavaScript supports UTF-8 encoding.
JavaScript★ 969↓ 20M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
npm
65Добрийіндекс здоров'я
emn178/js-sha3
A simple SHA-3 / Keccak hash function for JavaScript supports UTF-8 encoding.
JavaScript★ 369↓ 16.6M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
NuGet
63Помірнийіндекс здоров'я
Unisys/NSign
NSign (/ˈensaɪn/) is a set of .Net libraries for HTTP Message Signatures (RFC 9421).
C#★ 2215 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io
63Помірнийіндекс здоров'я
constantoine/totp-rs
RFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
npm
63Помірнийіндекс здоров'я
emn178/js-md5
A simple MD5 hash function for JavaScript supports UTF-8 encoding.
JavaScript★ 837↓ 28.7M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
Packagist
62Помірнийіндекс здоров'я
remotemerge/totp-php
Lightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3 462/міс19 вер. 2026 р.
MIT19 вер. 2026 р. · метрики 2.10.0
Go
56Помірнийіндекс здоров'я
ubgo/crypt
Batteries-included Go cryptography library: AES-256-GCM & ChaCha20-Poly1305 authenticated encryption, argon2id/bcrypt password hashing, HMAC & Ed25519 signing, HKDF, key rotation, KMS envelope encryption, and secure random — safe defaults, stdlib-only, byte-for-byte interop with the TypeScript crypt-ts.
Go★ 110 вер. 2026 р.
Apache-2.010 вер. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
jedisct1/rust-hmac-sha256
A small, self-contained SHA256 and HMAC-SHA256 implementation.
Rust★ 39↓ 2.2M/міс25 вер. 2026 р.
ISC25 вер. 2026 р. · метрики 2.10.0
npm · PyPI
54Помірнийіндекс здоров'я
signaltech-org/bolthub-sdk
Source for bolthub's published SDK packages (npm @bolthub/*, PyPI bolthub)
TypeScript · Python★ 0↓ 1 278/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
npm
53Помірнийіндекс здоров'я
emartech/escher-js
Library for HTTP request signing (JavaScript implementation)
JavaScript★ 12↓ 67.8K/міс22 жовт. 2026 р.
MIT22 жовт. 2026 р. · метрики 2.10.0
PyPI · crates.io · Go
48Слабкийіндекс здоров'я
bokelleher/sesame-sdk
Portable SDK and conformance vectors for SESAME, the proposed SCTE 130-9 security layer for the ESAM interface: HMAC auth, channel-scoped authorization, and AES-256-GCM payload encryption over HTTP headers.
Rust · C++ · Python★ 2↓ 172/міс16 вер. 2026 р.
Apache-2.016 вер. 2026 р. · метрики 2.10.0
crates.io
44Слабкийіндекс здоров'я
jedisct1/rust-hmac-sha1
SHA1 and HMAC-SHA1 for Rust.
Rust★ 8↓ 528.4K/міс25 вер. 2026 р.
ISC25 вер. 2026 р. · метрики 2.10.0
crates.io
44Слабкийіндекс здоров'я
jedisct1/rust-hmac-sha512
A small, self-contained SHA512 and HMAC-SHA512 implementation.
Rust★ 11↓ 1M/міс25 вер. 2026 р.
ISC25 вер. 2026 р. · метрики 2.10.0