Усі теги
Тег каталогу

#validation

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

562 записи
З тегом «validation»Упорядковано за індексом здоров'я
npm
54Помірнийіндекс здоров'я
Ecube-Labs/koa-x-router
`koa-x-router` is a library that extends the functionality of `@koa/router` by providing validation and automatic API documentation features. It simplifies the process of defining routes, validating request data, and generating API documentation.
TypeScript★ 5↓ 1 934/міс10 вер. 2026 р.
Без ліцензії10 вер. 2026 р. · метрики 2.10.0
PyPI
54Помірнийіндекс здоров'я
PunctumActus/cks-core
The single source of canonical truth — immutable, verifiable knowledge for humans and AI.
Python★ 1↓ 1 592/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
RIAEvangelist/strong-type
Strongly Typed native JS without a hard requirement for transpiling. What TypeScript should have been.
JavaScript · HTML★ 8↓ 313.2K/міс24 вер. 2026 р.
MIT24 вер. 2026 р. · метрики 2.10.0
Packagist
54Помірнийіндекс здоров'я
craftcms/laravel-ruleset-validation
Validate requests and objects with reusable Laravel rulesets.
PHP★ 2↓ 9 744/міс13 вер. 2026 р.
MIT13 вер. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
csstree/csstree
A tool set for CSS including fast detailed parser, walker, generator and lexer based on W3C specs and browser implementations
JavaScript★ 2 120↓ 404M/міс16 вер. 2026 р.
MIT16 вер. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
jesusgraterol/web-utils-kit
The web-utils-kit package provides a collection of well-tested and thoroughly documented utility functions for various web development needs. Each function adheres to a strict coding style and best practices to ensure consistency and maintainability.
TypeScript★ 0↓ 2 706/міс13 вер. 2026 р.
MIT13 вер. 2026 р. · метрики 2.10.0
NuGet
54Помірнийіндекс здоров'я
johnkors/NoCommonsNET
Port av NoCommons-biblioteket for .NET
C#★ 1415 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
Packagist
54Помірнийіндекс здоров'я
korridor/laravel-model-validation-rules
This package is an alternative to the Laravel built-in validation rules exists and unique. It uses Eloquent models instead of directly querying the database.
PHP★ 29↓ 14.4K/міс11 вер. 2026 р.
MIT11 вер. 2026 р. · метрики 2.10.0
NuGet
54Помірнийіндекс здоров'я
lira92/flunt.br
Extensions of Flunt for Brazilian projects
C#★ 5117 жовт. 2026 р.
MIT17 жовт. 2026 р. · метрики 2.10.0
Packagist
54Помірнийіндекс здоров'я
opis/json-schema
JSON Schema validator for PHP
PHP★ 655↓ 3.2M/міс27 серп. 2026 р.
Apache-2.027 серп. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
theRizwan/llm-guard
A TypeScript library for validating and securing LLM prompts — PII, jailbreak, prompt injection, profanity, toxicity and relevance guards. Zero-config defaults, extensible with custom patterns.
TypeScript · JavaScript★ 5↓ 5 291/міс7 вер. 2026 р.
MIT7 вер. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
validpilot/ai-verify-mcp
Опис репозиторію не опубліковано.
JavaScript★ 0↓ 437/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
npm
54Помірнийіндекс здоров'я
voltex-viewer/voltex
Опис репозиторію не опубліковано.
TypeScript★ 38 вер. 2026 р.
MIT8 вер. 2026 р. · метрики 2.10.0
crates.io
54Помірнийіндекс здоров'я
zs-dima/prost-protovalidate
Protobuf message validation for prost/Tonic with CEL evaluation. Full bufbuild conformance: 2854/2854.
Rust★ 25↓ 105.2K/міс20 жовт. 2026 р.
Apache-2.020 жовт. 2026 р. · метрики 2.10.0
Packagist
53Помірнийіндекс здоров'я
123inkt/symfony-request-validation
Request validation for symfony
PHP★ 12↓ 1 710/міс11 вер. 2026 р.
MIT11 вер. 2026 р. · метрики 2.10.0
npm
53Помірнийіндекс здоров'я
SorinGFS/idn-hostname
An internationalized hostname validator as defined by RFC5890, RFC5891, RFC5892, RFC5893, RFC3492 and UTS#46
JavaScript★ 0↓ 599.2K/міс13 вер. 2026 р.
MIT13 вер. 2026 р. · метрики 2.10.0
PyPI
53Помірнийіндекс здоров'я
Xuqing0415/phase-barrier
Stage-gate framework that forces coding agents to follow real engineering SOP: spec -> tests -> implementation, with verifiable evidence required at every step. 13 language adapters, tool interception, HMAC-signed state.
Python★ 2↓ 2 339/міс21 жовт. 2026 р.
MIT21 жовт. 2026 р. · метрики 2.10.0
Go
53Помірнийіндекс здоров'я
h2non/filetype
Fast, dependency-free Go package to infer binary file types based on the magic numbers header signature
Go★ 2 29919 вер. 2026 р.
MIT19 вер. 2026 р. · метрики 2.10.0
NuGet
53Помірнийіндекс здоров'я
lateapexearlyspeed/Lateapexearlyspeed.JsonSchema
High-performance .NET JSON Schema validator implementation based on System.Text.Json. Supports Draft 7, 2019-09, and 2020-12; includes fluent validation and schema creation from .NET types.
C#★ 10712 вер. 2026 р.
BSD-3-Clause12 вер. 2026 р. · метрики 2.10.0
PyPI
53Помірнийіндекс здоров'я
mike-oakley/openapi-pydantic
Modern, type-safe OpenAPI schemas in Python using Pydantic 1.8+ and 2.x
Python★ 123↓ 49.7M/міс16 вер. 2026 р.
Власна ліцензія16 вер. 2026 р. · метрики 2.10.0
npm
53Помірнийіндекс здоров'я
reowens/dotmd
CLI + Claude Code plugin for managing markdown docs with YAML frontmatter — index, query, validate, graph, lifecycle-manage plans/ADRs/RFCs, Notion sync, AI summaries
JavaScript★ 0↓ 5 355/міс9 вер. 2026 р.
MIT9 вер. 2026 р. · метрики 2.10.0
npm
53Помірнийіндекс здоров'я
stevekinney/agent-bureau
Опис репозиторію не опубліковано.
TypeScript★ 3↓ 88.5K/міс14 вер. 2026 р.
Без ліцензії14 вер. 2026 р. · метрики 2.10.0
npm
51Помірнийіндекс здоров'я
Uluops/-uluops-cli
Unified CLI for UluOps - validation tracking and registry management
TypeScript★ 0↓ 823/міс8 вер. 2026 р.
MIT8 вер. 2026 р. · метрики 2.10.0
Packagist
51Помірнийіндекс здоров'я
cakephp/validation
[READ-ONLY] Validation library from CakePHP. This repo is a split of the main code that can be found in https://github.com/cakephp/cakephp
PHP★ 43↓ 11.2K/міс21 жовт. 2026 р.
Власна ліцензія21 жовт. 2026 р. · метрики 2.10.0
npm
51Помірнийіндекс здоров'я
harshit-d3v/input-kit-phone
Headless React phone input with full world country codes, libphonenumber-powered formatting/validation, and TypeScript. Zero styling opinions.
TypeScript · HTML★ 0↓ 1 226/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io
51Помірнийіндекс здоров'я
magiclen/validators
A library for validating and modeling user input.
Rust★ 24↓ 161.4K/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
PyPI
51Помірнийіндекс здоров'я
sablier-ai/finval
Rigorous validation for synthetic financial time series — 19 financial stylized-fact metrics, used as the FinBench scoring backend
Python★ 1↓ 344/міс14 вер. 2026 р.
MIT14 вер. 2026 р. · метрики 2.10.0
Packagist
51Помірнийіндекс здоров'я
syntatis/utils-php
🧰 Handy PHP functions
PHP★ 7↓ 3 627/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
npm · Go
50Помірнийіндекс здоров'я
Hossiy21/razify
A developer CLI tool that manages .env files, detects secret leaks, syncs env drift across teammates, and validates environment parity between local/staging/prod all from your terminal. Written in Go.
Go · TypeScript★ 20↓ 22/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
npm
50Помірнийіндекс здоров'я
IntegerAlex/disposable-email-detector
This repository contains a Node.js utility for detecting disposable email addresses. It helps identify whether an email address belongs to a disposable email provider, aiding in the prevention of spam and unwanted sign-ups.
TypeScript · JavaScript★ 34↓ 19.5K/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0