全部标签
目录标签

#stun

公开记录中带有此标签的全部仓库——标签来自其 GitHub 主题或软件包注册表发布的关键词。健康度量遵循与记录其余部分相同的版本化方法论。

17 条记录
标签为“stun”按健康指数排序
Go
94卓越健康指数
pion/turn
Pion TURN, an API for building TURN clients and servers
Go★ 2,2552026年9月23日
MIT2026年9月23日 · 指标 2.10.0
Go
90优秀健康指数
pion/stun
A Go implementation of STUN
Go★ 8622026年10月21日
MIT2026年10月21日 · 指标 2.10.0
NuGet
89优秀健康指数
sipsorcery-org/sipsorcery
A WebRTC, SIP and VoIP library for C# and .NET. Designed for real-time communications apps.
C#★ 1,9372026年9月11日
自定义许可证2026年9月11日 · 指标 2.10.0
NuGet
77良好健康指数
HMBSbige/NatTypeTester
测试当前网络的 NAT 类型(STUN)
C#★ 4,8472026年9月16日
MIT2026年9月16日 · 指标 2.10.0
crates.io
71良好健康指数
ystreet/stun-proto
A (sans-IO) implementation of the STUN (RFC5389/RFC8489) protocol written in Rust
Rust★ 16↓ 16.8K/月2026年9月15日
Apache-2.02026年9月15日 · 指标 2.10.0
Go
69良好健康指数
pilot-protocol/beacon
Pilot Protocol beacon — STUN/NAT-punch/relay service co-deployed with rendezvous at the network edge
Go★ 12026年9月19日
AGPL-3.02026年9月19日 · 指标 2.10.0
Go
60中等健康指数
ccding/go-stun
A go implementation of the STUN client (RFC 3489 and RFC 5389)
Go★ 7232026年9月14日
Apache-2.02026年9月14日 · 指标 2.10.0
crates.io
60中等健康指数
kbalt/ezk
EZK is a collection of Rust crates to build SIP applications
Rust★ 49↓ 15.8K/月2026年9月9日
MIT2026年9月9日 · 指标 2.10.0
Hex
59中等健康指数
processone/stun
STUN and TURN library for Erlang / Elixir
Erlang★ 255↓ 5,059/月2026年9月12日
Apache-2.02026年9月12日 · 指标 2.10.0
crates.io
57中等健康指数
DIG-Network/dig-nat
DIG NAT traversal — abstract peer connection over UPnP/IGD, PCP (RFC 6887), NAT-PMP, direct (port-forwarded), with relay.dig.net as last-resort fallback. One connect() API; the traversal method is transparent to callers.
Rust★ 0↓ 3,185/月2026年9月18日
无许可证2026年9月18日 · 指标 2.10.0
Packagist
54中等健康指数
danog/php-rtc-ice
WebRTC ICE connectivity in PHP, ported to Amp v3 fibers and sockets. MadelineProto's PHP 8.2+ fork integrates the modular danog/php-rtc STUN, TURN, and mDNS stack.
PHP★ 0↓ 2,040/月2026年9月19日
BSD-3-Clause2026年9月19日 · 指标 2.10.0
Packagist
50中等健康指数
danog/php-rtc-stun
STUN transactions and NAT discovery for PHP, ported to Amp v3 sockets and fibers. MadelineProto's PHP 8.2+ fork supports the modular danog/php-rtc stack.
PHP★ 0↓ 2,409/月2026年9月18日
BSD-3-Clause2026年9月18日 · 指标 2.10.0
Go
50中等健康指数
donomii/brk
Message-level reliable UDP for Go: acknowledged retries, receipts, duplicate suppression, HMAC authentication, STUN and hole punching.
Go★ 12026年9月5日
GPL-3.02026年9月5日 · 指标 2.10.0
Go
50中等健康指数
oneclickvirt/gostun
本机NAT类型检测工具(Local NAT type detection tool)(NatTypeTester)
Go★ 742026年9月14日
Apache-2.02026年9月14日 · 指标 2.10.0
Go
45薄弱健康指数
Snawoot/myip
Get your external IP address using multiple STUN servers
Makefile · Go★ 482026年9月12日
MIT2026年9月12日 · 指标 2.10.0
Hex
42薄弱健康指数
elixir-webrtc/ex_stun
Implementation of STUN protocol (RFC 8489)
Elixir★ 7↓ 7,873/月2026年9月9日
Apache-2.02026年9月9日 · 指标 2.10.0
Go
35薄弱健康指数
Snawoot/extip
Go package which retrieves external address IP using STUN servers
Go★ 82026年9月10日
MIT2026年9月10日 · 指标 2.10.0