Todas las etiquetas
Etiqueta del catálogo

#stun

Todos los repositorios del registro público que llevan esta etiqueta, procedente de sus topics de GitHub o de las palabras clave que publican sus registros de paquetes. La salud se mide con la misma metodología versionada que el resto del registro.

17 registros
Con la etiqueta «stun»Ordenado por índice de salud
Go
94Excepcionalíndice de salud
pion/turn
Pion TURN, an API for building TURN clients and servers
Go★ 225523 sept 2026
MIT23 sept 2026 · métricas 2.10.0
Go
90Excelenteíndice de salud
pion/stun
A Go implementation of STUN
Go★ 86221 oct 2026
MIT21 oct 2026 · métricas 2.10.0
NuGet
89Excelenteíndice de salud
sipsorcery-org/sipsorcery
A WebRTC, SIP and VoIP library for C# and .NET. Designed for real-time communications apps.
C#★ 193711 sept 2026
Licencia propia11 sept 2026 · métricas 2.10.0
NuGet
77Buenoíndice de salud
HMBSbige/NatTypeTester
测试当前网络的 NAT 类型(STUN)
C#★ 484716 sept 2026
MIT16 sept 2026 · métricas 2.10.0
crates.io
71Buenoíndice de salud
ystreet/stun-proto
A (sans-IO) implementation of the STUN (RFC5389/RFC8489) protocol written in Rust
Rust★ 16↓ 16.8K/mes15 sept 2026
Apache-2.015 sept 2026 · métricas 2.10.0
Go
69Buenoíndice de salud
pilot-protocol/beacon
Pilot Protocol beacon — STUN/NAT-punch/relay service co-deployed with rendezvous at the network edge
Go★ 119 sept 2026
AGPL-3.019 sept 2026 · métricas 2.10.0
Go
60Moderadoíndice de salud
ccding/go-stun
A go implementation of the STUN client (RFC 3489 and RFC 5389)
Go★ 72314 sept 2026
Apache-2.014 sept 2026 · métricas 2.10.0
crates.io
60Moderadoíndice de salud
kbalt/ezk
EZK is a collection of Rust crates to build SIP applications
Rust★ 49↓ 15.8K/mes9 sept 2026
MIT9 sept 2026 · métricas 2.10.0
Hex
59Moderadoíndice de salud
processone/stun
STUN and TURN library for Erlang / Elixir
Erlang★ 255↓ 5059/mes12 sept 2026
Apache-2.012 sept 2026 · métricas 2.10.0
crates.io
57Moderadoíndice de salud
DIG-Network/dig-nat
DIG NAT traversal — abstract peer connection over UPnP/IGD, PCP (RFC 6887), NAT-PMP, direct (port-forwarded), with relay.dig.net as last-resort fallback. One connect() API; the traversal method is transparent to callers.
Rust★ 0↓ 3185/mes18 sept 2026
Sin licencia18 sept 2026 · métricas 2.10.0
Packagist
54Moderadoíndice de salud
danog/php-rtc-ice
WebRTC ICE connectivity in PHP, ported to Amp v3 fibers and sockets. MadelineProto's PHP 8.2+ fork integrates the modular danog/php-rtc STUN, TURN, and mDNS stack.
PHP★ 0↓ 2040/mes19 sept 2026
BSD-3-Clause19 sept 2026 · métricas 2.10.0
Packagist
50Moderadoíndice de salud
danog/php-rtc-stun
STUN transactions and NAT discovery for PHP, ported to Amp v3 sockets and fibers. MadelineProto's PHP 8.2+ fork supports the modular danog/php-rtc stack.
PHP★ 0↓ 2409/mes18 sept 2026
BSD-3-Clause18 sept 2026 · métricas 2.10.0
Go
50Moderadoíndice de salud
donomii/brk
Message-level reliable UDP for Go: acknowledged retries, receipts, duplicate suppression, HMAC authentication, STUN and hole punching.
Go★ 15 sept 2026
GPL-3.05 sept 2026 · métricas 2.10.0
Go
50Moderadoíndice de salud
oneclickvirt/gostun
本机NAT类型检测工具(Local NAT type detection tool)(NatTypeTester)
Go★ 7414 sept 2026
Apache-2.014 sept 2026 · métricas 2.10.0
Go
45Débilíndice de salud
Snawoot/myip
Get your external IP address using multiple STUN servers
Makefile · Go★ 4812 sept 2026
MIT12 sept 2026 · métricas 2.10.0
Hex
42Débilíndice de salud
elixir-webrtc/ex_stun
Implementation of STUN protocol (RFC 8489)
Elixir★ 7↓ 7873/mes9 sept 2026
Apache-2.09 sept 2026 · métricas 2.10.0
Go
35Débilíndice de salud
Snawoot/extip
Go package which retrieves external address IP using STUN servers
Go★ 810 sept 2026
MIT10 sept 2026 · métricas 2.10.0