All tags
Catalogue tag

#httpclient

Every repository in the public record carrying this tag — from its GitHub topics or the keywords its package registries publish. Health is measured under the same versioned methodology as the rest of the record.

85 records
Tagged “httpclient”Ranked by health index
NuGet · npm
62Moderatehealth index
thomhurst/Kevlar
Fast, readable resilience for .NET.
C#★ 14Sep 18, 2026
MITSep 18, 2026 · metrics 2.10.0
NuGet
60Moderatehealth index
Adolfok3/AuthorizationInterceptor
A simple and lightweight .NET package designed to streamline HttpClient authenticated requests
C#★ 6Sep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
Go
60Moderatehealth index
phcp-tech/common-library-golang
Common library golang for PHCP ecosystem.
Go★ 8Sep 10, 2026
Apache-2.0Sep 10, 2026 · metrics 2.10.0
Packagist
60Moderatehealth index
php-http/httplug
HTTPlug, the HTTP client abstraction for PHP
PHP★ 2,590↓ 6.8M/moAug 27, 2026
MITAug 27, 2026 · metrics 2.10.0
Packagist
59Moderatehealth index
Yurunsoft/YurunHttp
YurunHttp 是开源的 PHP HTTP 客户端,支持链式操作,简单易用。完美支持Curl、Swoole 协程。QQ群:17916227
PHP★ 259↓ 3,962/moSep 13, 2026
MITSep 13, 2026 · metrics 2.10.0
NuGet
59Moderatehealth index
ZitchCode/SecureHttpClient
Cross-platform HttpClientHandler with TLS1.2 and Certificate Pinning
C#★ 42Aug 26, 2026
MITAug 26, 2026 · metrics 2.10.0
NuGet
57Moderatehealth index
NLog/NLog.Targets.WebService
NLog target for sending logevents as REST HTTP method requests
C#★ 1Sep 13, 2026
BSD-3-ClauseSep 13, 2026 · metrics 2.10.0
NuGet
57Moderatehealth index
simplify9/SW-HttpExtensions
.NET library of HTTP client extensions and API client abstractions, published as SimplyWorks.HttpExtensions
C#★ 3Sep 14, 2026
No licenseSep 14, 2026 · metrics 2.10.0
NuGet
56Moderatehealth index
saguiitay/WebDAVClient
Strongly-typed, async WebDAV Client implementation in C#
C#★ 134Oct 20, 2026
Custom licenseOct 20, 2026 · metrics 2.10.0
NuGet
51Moderatehealth index
Hawxy/Auth0Net.DependencyInjection
Dependency Injection & HttpClientFactory extensions for Auth0.NET
C#★ 48Sep 9, 2026
MITSep 9, 2026 · metrics 2.10.0
—
51Moderatehealth index
thunderclient/thunder-client-support
Thunder Client is a lightweight Rest API Client Extension for VS Code.
Mixed★ 3,724Sep 15, 2026
Custom licenseSep 15, 2026 · metrics 2.10.0
NuGet
50Moderatehealth index
alexbypa/CSharp.Essentials
Helper library for C# Projects
C#★ 2Oct 6, 2026
MITOct 6, 2026 · metrics 2.10.0
NuGet
48Weakhealth index
sabatex/Core
This library extended .NET (DateTime,Char,String,Enum)
C# · HTML★ 1Oct 14, 2026
MITOct 14, 2026 · metrics 2.10.0
NuGet
47Weakhealth index
Peymanpn/Pdsr.HttpClient
Customized .NET HttpClient
C#★ 1Oct 6, 2026
Apache-2.0Oct 6, 2026 · metrics 2.10.0
NuGet
45Weakhealth index
jchristn/RestWrapper
RestWrapper is a simple C# class library to help simplify sending REST API requests and retrieving responses (RESTful HTTP and HTTPS)
C#★ 29Sep 18, 2026
MITSep 18, 2026 · metrics 2.10.0
NuGet
44Weakhealth index
DeLaphante/CynkyAutomation
Powered by Selenium and Reqnroll with detailed HTML reporting, Automatic Element Waiting & Logging capabilities - CynkyAutomation framework can handle any website that is built using AJAX, React, AngularJS, Vue.js, Single Page Applications, Salesforce, Dynamics 365 CRM and many more.
C#★ 14Oct 20, 2026
MITOct 20, 2026 · metrics 2.10.0
NuGet
44Weakhealth index
oatsoda/TeePee
A fluent API to configure HttpClients for unit testing.
C#★ 4Sep 19, 2026
No licenseSep 19, 2026 · metrics 2.10.0
Packagist
34At Riskhealth index
yiisoft/yii2-httpclient
Yii 2 HTTP client
PHP★ 429↓ 218.8K/moSep 15, 2026
BSD-3-ClauseSep 15, 2026 · metrics 2.10.0
Go
31At Riskhealth index
nativebpm/httpstream
Stream-first HTTP client for Go. Efficient, zero-buffer streaming for large HTTP payloads.
Go★ 3Oct 20, 2026
No licenseOct 20, 2026 · metrics 2.10.0
Go
30At Riskhealth index
tobycroft/TuuzNet
TuuzNet is a Network package for http request curl and websocket, focus in high performance but simple use.
Go★ 0Sep 14, 2026
No licenseSep 14, 2026 · metrics 2.10.0
npm
27At Riskhealth index
prettymuchbryce/http-status-codes
Constants enumerating the HTTP status codes. All status codes defined in RFC1945 (HTTP/1.0, RFC2616 (HTTP/1.1), and RFC2518 (WebDAV) are supported.
TypeScript★ 1,120↓ 31.6M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
NuGet
27At Riskhealth index
rushfrisby/InterfaceRpc
Turn your interface into an RPC service
C#★ 2Sep 26, 2026
Apache-2.0Sep 26, 2026 · metrics 2.10.0
Packagist
26At Riskhealth index
pear/HTTP_Request2
Provides an easy way to perform HTTP requests (and does not require curl extension for this).
PHP★ 77↓ 49.3K/moOct 21, 2026
No licenseOct 21, 2026 · metrics 2.10.0
NuGet
14Criticalhealth index
App-vNext/Polly.Extensions.Http
Polly.Extensions.Http is an extensions package containing opinionated convenience methods for configuring Polly policies to handle transient faults typical of calls through HttpClient.
C# · PowerShell★ 85Sep 11, 2026
Custom licenseSep 11, 2026 · metrics 2.10.0