All tags
Catalogue tag

#validator

Every repository in the public record carrying this tag — from its GitHub topics or the keywords its package registries publish. Health is measured under the same versioned methodology as the rest of the record.

189 records
Tagged “validator”Ranked by health index
npm
47Weakhealth index
Sammons/typed-mind-lang
No repository description published.
TypeScript · JavaScript★ 2↓ 3,794/moOct 18, 2026
MITOct 18, 2026 · metrics 2.10.0
Packagist
47Weakhealth index
ez-php/validation
No repository description published.
PHP★ 0↓ 2,578/moSep 18, 2026
No licenseSep 18, 2026 · metrics 2.10.0
Packagist
47Weakhealth index
orisai/nette-object-mapper
Orisai Object Mapper integration for Nette
PHP★ 4↓ 2,074/moSep 30, 2026
MPL-2.0Sep 30, 2026 · metrics 2.10.0
npm
43Weakhealth index
tdegrunt/jsonschema
JSON Schema validation
JavaScript★ 1,875↓ 23.3M/moSep 17, 2026
Custom licenseSep 17, 2026 · metrics 2.10.0
Go
42Weakhealth index
WoozyMasta/rvmat
Go library for parsing, validating, and writing Real Virtuality RVMAT material files with procedural texture support and deterministic formatting
Go★ 0Sep 19, 2026
MITSep 19, 2026 · metrics 2.10.0
npm
42Weakhealth index
bnurbekov/company-email-validator
Checks whether an email is a company email (useful for B2B forms)
JavaScript★ 66↓ 412K/moSep 13, 2026
UnlicenseSep 13, 2026 · metrics 2.10.0
Packagist
42Weakhealth index
componenta/validation
No repository description published.
PHP★ 0↓ 1,416/moSep 18, 2026
No licenseSep 18, 2026 · metrics 2.10.0
npm
42Weakhealth index
electrovir/parse-email-address
Parse/validate email addresses, primarily using RFC-5321.
TypeScript · JavaScript★ 0↓ 50.4K/moOct 20, 2026
CC0-1.0Oct 20, 2026 · metrics 2.10.0
Go
41Weakhealth index
cohesivestack/valgopt
Valgopt provides a set of validators for the Valgo validation library that work seamlessly with optional value types from the Opt library.
Go★ 1Sep 19, 2026
MITSep 19, 2026 · metrics 2.10.0
PyPI
39Weakhealth index
naimetti/rfc3339-validator
A pure python RFC3339 validator
Python · Makefile★ 8↓ 69.3M/moSep 9, 2026
MITSep 9, 2026 · metrics 2.10.0
PyPI
38Weakhealth index
willynilly/rfc3987-syntax
Helper functions to syntactically validate strings according to RFC 3987.
Python★ 1↓ 35.9M/moAug 27, 2026
MITAug 27, 2026 · metrics 2.10.0
npm
35Weakhealth index
OjasKord/url-safety-validator-mcp
AI-powered URL safety validator MCP server. SAFE/SUSPICIOUS/DANGEROUS verdict for agents.
JavaScript★ 1↓ 862/moSep 11, 2026
MITSep 11, 2026 · metrics 2.10.0
npm
35Weakhealth index
WangShai123/vanilla-jui
A lightweight, reactive, and fully customizable vanilla JS UI library.
TypeScript · CSS★ 0↓ 8,139/moSep 14, 2026
No licenseSep 14, 2026 · metrics 2.10.0
npm
35Weakhealth index
ajv-validator/ajv-draft-04
Ajv JSON validator for JSON Schema draft-04
TypeScript · JavaScript★ 11↓ 61.3M/moSep 15, 2026
MITSep 15, 2026 · metrics 2.10.0
Go
35Weakhealth index
danilosciarra/guard
A lightweight Go validator library with recursive struct validation, custom validators, and typed errors
Go★ 0Oct 19, 2026
MITOct 19, 2026 · metrics 2.10.0
npm
35Weakhealth index
soryy708/il-bank-account-validator
JavaScript module for Israeli Bank Account validation (sanity checking) if an account number is valid for a particular Israeli bank and branch.
JavaScript★ 10↓ 277/moSep 9, 2026
MITSep 9, 2026 · metrics 2.10.0
Packagist
34At Riskhealth index
egulias/EmailValidator
PHP Email address validator
PHP★ 11.6K↓ 16.7M/moAug 27, 2026
MITAug 27, 2026 · metrics 2.10.0
npm
34At Riskhealth index
ianstormtaylor/superstruct
A simple and composable way to validate data in JavaScript (and TypeScript).
TypeScript★ 7,130↓ 23.9M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
Packagist
34At Riskhealth index
laminas/laminas-validator
Validation classes for a wide range of domains, and the ability to chain validators to create complex validation criteria
PHP★ 160↓ 1.2M/moSep 13, 2026
BSD-3-ClauseSep 13, 2026 · metrics 2.10.0
npm
34At Riskhealth index
sourcey/mcp-parser
Parse, validate, and snapshot MCP servers. The swagger-parser for MCP.
TypeScript★ 2↓ 6,153/moSep 4, 2026
MITSep 4, 2026 · metrics 2.10.0
Go
34At Riskhealth index
sshaplygin/docs-code
Official documents codes validation and generation in Go
Go★ 7Oct 20, 2026
MITOct 20, 2026 · metrics 2.10.0
Packagist
34At Riskhealth index
yiisoft/validator
Yii validator library
PHP★ 167↓ 29.7K/moSep 12, 2026
BSD-3-ClauseSep 12, 2026 · metrics 2.10.0
Packagist
33At Riskhealth index
totara/htmlpurifier-html5
HTML5 support for HTMLPurifier
PHP★ 0↓ 2,641/moSep 18, 2026
MITSep 18, 2026 · metrics 2.10.0
npm
33At Riskhealth index
viesapi/viesapi-javascript-client
VIES API Client for JavaScript
JavaScript★ 0↓ 6,000/moSep 28, 2026
Apache-2.0Sep 28, 2026 · metrics 2.10.0
PyPI
31At Riskhealth index
naimetti/rfc3986-validator
Pure python RFC3986 validator
Python · Makefile★ 4↓ 37.5M/moSep 9, 2026
MITSep 9, 2026 · metrics 2.10.0
npm
30At Riskhealth index
ajv-validator/ajv-keywords
Additional JSON-Schema keywords for Ajv JSON validator
TypeScript★ 257Sep 13, 2026
MITSep 13, 2026 · metrics 2.10.0