
authelia/autheliaThe Single Sign-On Multi-Factor portal for web apps. OpenID Certified™ and Post-Quantum Cryptography Ready.
Go · TypeScript★ 29K2026年9月16日

logto-io/logto🧑🚀 Authentication and authorization infrastructure for SaaS and AI apps, built on OIDC and OAuth 2.1 with multi-tenancy, SSO, and RBAC.
TypeScript★ 14.6K↓ 29.3K/月2026年9月19日

Spomky-Labs/otphp:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
PHP★ 1,489↓ 1.8M/月2026年9月9日

yeojz/otplibOne Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2,292↓ 51.3M/月2026年9月17日

authup/authupSelf-hosted authentication & authorization system (IAM: OAuth2 & OpenID Connect provider with realms, RBAC & ABAC policies, MFA (TOTP, passkeys, email OTP), identity federation (OIDC, LDAP) and session management.
TypeScript · Vue★ 40↓ 13.4K/月2026年9月13日
PHP★ 2,007↓ 6.9M/月2026年8月27日

hectorm/otpauthOne Time Password (HOTP/TOTP) library for Node.js, Deno, Bun and browsers.
JavaScript★ 1,484↓ 12M/月2026年10月11日
C#★ 2432026年9月9日

scito/extract_otp_secretsExtract one time password (OTP) secrets from QR codes exported by two-factor authentication (2FA) apps such as "Google Authenticator". The exported QR codes from authentication apps can be captured by camera, read from images, or read from text files. The secrets can be exported to JSON or CSV, or printed as QR codes to console.
Python · Shell★ 1,6602026年9月20日
JavaScript · PHP★ 8↓ 6,593/月2026年9月12日

infocyph/OTPSimple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/月2026年9月7日
Go★ 3042026年10月18日

ZYLVEXT/litestar-authFail-closed human and workload authentication for Python and Litestar: opaque sessions, mTLS, DPoP, SPIFFE, webhooks, and HTTP signatures.
Python★ 3↓ 2,701/月2026年8月23日
TypeScript★ 8↓ 37.6K/月2026年9月18日
TypeScript · Kotlin · Swift★ 5↓ 26.9K/月2026年9月15日

replydev/cotpEncrypted, command-line TOTP/HOTP authenticator app with import functionality.
Rust★ 385↓ 109/月2026年9月18日
TypeScript · MDX★ 5↓ 17.5K/月2026年9月18日

askrjs/askr-authShared authentication contracts and request authentication for Askr.
TypeScript★ 1↓ 3,065/月2026年9月16日

JLugagne/egauthComposable, non-opinionated authentication toolkit for Go — import the modules you need (identity, tokens/JWT, sessions, passkeys, OAuth/OIDC, MFA, OTP) and wire them with DI. Secure-by-default, no framework.
Go★ 02026年9月16日
C★ 5582026年9月10日
TypeScript★ 81↓ 385.9K/月2026年10月4日
TypeScript★ 2↓ 36.9K/月2026年9月18日

constantoine/totp-rsRFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/月2026年9月17日

usestapel/stapel-authFull-featured authentication Django app — JWT, passkeys, TOTP, QR, OAuth, SSO, magic link
Python★ 0↓ 4,163/月2026年9月6日

remotemerge/totp-phpLightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3,462/月2026年9月19日

gabrielesbaiz/nova-two-factorTwo-factor authentication for Laravel Nova 5: TOTP, passkeys, email codes, enforcement policies and step-up re-auth.
PHP★ 2↓ 2,365/月2026年10月9日

MincDev/php-otpauthA lightweight PHP library for generating and validating TOTP authentication codes and QR codes compatible with Google Authenticator, Microsoft Authenticator, Authy, 1Password, Bitwarden, and other RFC 6238 authenticator apps.
PHP★ 5↓ 4,473/月2026年10月20日
Python★ 3,334↓ 42.2M/月2026年8月27日
JavaScript · Go Template★ 132026年10月22日

Sammy-T/avdaA desktop app for generating and viewing one-time passwords from Aegis Authenticator backups.
Svelte · NSIS · JavaScript★ 642026年10月21日