Усі теги
Тег каталогу

#totp

Усі репозиторії публічного реєстру з цим тегом — із тем GitHub або ключових слів, які публікують їхні реєстри пакетів. Здоров'я вимірюється за тією ж версіонованою методологією, що й решта реєстру.

46 записів
З тегом «totp»Упорядковано за індексом здоров'я
Go · npm
100Винятковийіндекс здоров'я
authelia/authelia
The Single Sign-On Multi-Factor portal for web apps. OpenID Certified™ and Post-Quantum Cryptography Ready.
Go · TypeScript★ 29K16 вер. 2026 р.
Apache-2.016 вер. 2026 р. · метрики 2.10.0
npm
96Винятковийіндекс здоров'я
logto-io/logto
🧑‍🚀 Authentication and authorization infrastructure for SaaS and AI apps, built on OIDC and OAuth 2.1 with multi-tenancy, SSO, and RBAC.
TypeScript★ 14.6K↓ 29.3K/міс19 вер. 2026 р.
MPL-2.019 вер. 2026 р. · метрики 2.10.0
Packagist
89Відміннийіндекс здоров'я
Spomky-Labs/otphp
:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
PHP★ 1 489↓ 1.8M/міс9 вер. 2026 р.
MIT9 вер. 2026 р. · метрики 2.10.0
npm
89Відміннийіндекс здоров'я
yeojz/otplib
One Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2 292↓ 51.3M/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
npm
88Відміннийіндекс здоров'я
authup/authup
Self-hosted authentication & authorization system (IAM: OAuth2 & OpenID Connect provider with realms, RBAC & ABAC policies, MFA (TOTP, passkeys, email OTP), identity federation (OIDC, LDAP) and session management.
TypeScript · Vue★ 40↓ 13.4K/міс13 вер. 2026 р.
AGPL-3.013 вер. 2026 р. · метрики 2.10.0
Packagist
86Відміннийіндекс здоров'я
antonioribeiro/google2fa
A One Time Password Authentication package, compatible with Google Authenticator.
PHP★ 2 007↓ 6.9M/міс27 серп. 2026 р.
MIT27 серп. 2026 р. · метрики 2.10.0
npm
86Відміннийіндекс здоров'я
hectorm/otpauth
One Time Password (HOTP/TOTP) library for Node.js, Deno, Bun and browsers.
JavaScript★ 1 484↓ 12M/міс11 жовт. 2026 р.
MIT11 жовт. 2026 р. · метрики 2.10.0
NuGet
83Відміннийіндекс здоров'я
WeihanLi/WeihanLi.Common
common tools, methods, extension methods, etc... .net 常用工具类,公共方法,常用扩展方法等,基础类库
C#★ 2439 вер. 2026 р.
Apache-2.09 вер. 2026 р. · метрики 2.10.0
PyPI
83Відміннийіндекс здоров'я
scito/extract_otp_secrets
Extract one time password (OTP) secrets from QR codes exported by two-factor authentication (2FA) apps such as "Google Authenticator". The exported QR codes from authentication apps can be captured by camera, read from images, or read from text files. The secrets can be exported to JSON or CSV, or printed as QR codes to console.
Python · Shell★ 1 66020 вер. 2026 р.
GPL-3.020 вер. 2026 р. · метрики 2.10.0
Packagist · npm
83Відміннийіндекс здоров'я
silverstripe/silverstripe-totp-authenticator
Provides a TOTP-based authentication method for the Silverstripe MFA module.
JavaScript · PHP★ 8↓ 6 593/міс12 вер. 2026 р.
BSD-3-Clause12 вер. 2026 р. · метрики 2.10.0
Packagist · PyPI
81Відміннийіндекс здоров'я
infocyph/OTP
Simple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/міс7 вер. 2026 р.
MIT7 вер. 2026 р. · метрики 2.10.0
Go
80Відміннийіндекс здоров'я
Luzifer/nginx-sso
SSO authentication provider for the auth_request nginx module
Go★ 30418 жовт. 2026 р.
Apache-2.018 жовт. 2026 р. · метрики 2.10.0
PyPI
78Добрийіндекс здоров'я
ZYLVEXT/litestar-auth
Fail-closed human and workload authentication for Python and Litestar: opaque sessions, mTLS, DPoP, SPIFFE, webhooks, and HTTP signatures.
Python★ 3↓ 2 701/міс23 серп. 2026 р.
MIT23 серп. 2026 р. · метрики 2.10.0
npm
78Добрийіндекс здоров'я
authsignal/authsignal-browser
Authsignal Web SDK for authenticating with passkeys, email OTP, SMS OTP and authenticator app (TOTP)
TypeScript★ 8↓ 37.6K/міс18 вер. 2026 р.
MIT18 вер. 2026 р. · метрики 2.10.0
npm · Maven
77Добрийіндекс здоров'я
authsignal/react-native-authsignal
Authsignal React Native SDK for authenticating with passkeys, push, email OTP, SMS OTP and authenticator app (TOTP)
TypeScript · Kotlin · Swift★ 5↓ 26.9K/міс15 вер. 2026 р.
MIT15 вер. 2026 р. · метрики 2.10.0
crates.io · PyPI
75Добрийіндекс здоров'я
replydev/cotp
Encrypted, command-line TOTP/HOTP authenticator app with import functionality.
Rust★ 385↓ 109/міс18 вер. 2026 р.
GPL-3.018 вер. 2026 р. · метрики 2.10.0
npm
71Добрийіндекс здоров'я
DavideCarvalho/adonis-agora-authkit
AuthKit — AdonisJS OIDC Authorization Server kit + OIDC client + React helpers (@dudousxd/adonis-authkit-*)
TypeScript · MDX★ 5↓ 17.5K/міс18 вер. 2026 р.
MIT18 вер. 2026 р. · метрики 2.10.0
npm
69Добрийіндекс здоров'я
askrjs/askr-auth
Shared authentication contracts and request authentication for Askr.
TypeScript★ 1↓ 3 065/міс16 вер. 2026 р.
Apache-2.016 вер. 2026 р. · метрики 2.10.0
Go
67Добрийіндекс здоров'я
JLugagne/egauth
Composable, non-opinionated authentication toolkit for Go — import the modules you need (identity, tokens/JWT, sessions, passkeys, OAuth/OIDC, MFA, OTP) and wire them with DI. Secure-by-default, no framework.
Go★ 016 вер. 2026 р.
MIT16 вер. 2026 р. · метрики 2.10.0
—
67Добрийіндекс здоров'я
paolostivanin/OTPClient
A secure, easy-to-use TOTP/HOTP client written in C with a GTK4/libadwaita interface.
C★ 55810 вер. 2026 р.
GPL-3.010 вер. 2026 р. · метрики 2.10.0
npm
65Добрийіндекс здоров'я
paulmillr/micro-key-producer
Produces secure keys and passwords. SSH, PGP, OTP, TOR, X509, OTP, SLIP10
TypeScript★ 81↓ 385.9K/міс4 жовт. 2026 р.
MIT4 жовт. 2026 р. · метрики 2.10.0
npm
65Добрийіндекс здоров'я
stacksjs/ts-auth
One-Time Passwords, WebAuthn, and more. Fully typed.
TypeScript★ 2↓ 36.9K/міс18 вер. 2026 р.
MIT18 вер. 2026 р. · метрики 2.10.0
crates.io
63Помірнийіндекс здоров'я
constantoine/totp-rs
RFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/міс17 вер. 2026 р.
MIT17 вер. 2026 р. · метрики 2.10.0
PyPI
63Помірнийіндекс здоров'я
usestapel/stapel-auth
Full-featured authentication Django app — JWT, passkeys, TOTP, QR, OAuth, SSO, magic link
Python★ 0↓ 4 163/міс6 вер. 2026 р.
MIT6 вер. 2026 р. · метрики 2.10.0
Packagist
62Помірнийіндекс здоров'я
remotemerge/totp-php
Lightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3 462/міс19 вер. 2026 р.
MIT19 вер. 2026 р. · метрики 2.10.0
Packagist · npm
57Помірнийіндекс здоров'я
gabrielesbaiz/nova-two-factor
Two-factor authentication for Laravel Nova 5: TOTP, passkeys, email codes, enforcement policies and step-up re-auth.
PHP★ 2↓ 2 365/міс9 жовт. 2026 р.
MIT9 жовт. 2026 р. · метрики 2.10.0
Packagist
56Помірнийіндекс здоров'я
MincDev/php-otpauth
A lightweight PHP library for generating and validating TOTP authentication codes and QR codes compatible with Google Authenticator, Microsoft Authenticator, Authy, 1Password, Bitwarden, and other RFC 6238 authenticator apps.
PHP★ 5↓ 4 473/міс20 жовт. 2026 р.
MIT20 жовт. 2026 р. · метрики 2.10.0
npm
56Помірнийіндекс здоров'я
NodeBB/nodebb-plugin-2factor
Two-Factor Authentication for NodeBB
JavaScript · Go Template★ 145 вер. 2026 р.
MIT5 вер. 2026 р. · метрики 2.10.0
PyPI
56Помірнийіндекс здоров'я
pyauth/pyotp
Python One-Time Password Library
Python★ 3 334↓ 42.2M/міс27 серп. 2026 р.
Власна ліцензія27 серп. 2026 р. · метрики 2.10.0
Go · npm
54Помірнийіндекс здоров'я
Sammy-T/avda
A desktop app for generating and viewing one-time passwords from Aegis Authenticator backups.
Svelte · NSIS · JavaScript★ 6421 жовт. 2026 р.
GPL-3.021 жовт. 2026 р. · метрики 2.10.0