Todas las etiquetas
Etiqueta del catálogo

#totp

Todos los repositorios del registro público que llevan esta etiqueta, procedente de sus topics de GitHub o de las palabras clave que publican sus registros de paquetes. La salud se mide con la misma metodología versionada que el resto del registro.

46 registros
Con la etiqueta «totp»Ordenado por índice de salud
Go · npm
100Excepcionalíndice de salud
authelia/authelia
The Single Sign-On Multi-Factor portal for web apps. OpenID Certified™ and Post-Quantum Cryptography Ready.
Go · TypeScript★ 29K16 sept 2026
Apache-2.016 sept 2026 · métricas 2.10.0
npm
96Excepcionalíndice de salud
logto-io/logto
🧑‍🚀 Authentication and authorization infrastructure for SaaS and AI apps, built on OIDC and OAuth 2.1 with multi-tenancy, SSO, and RBAC.
TypeScript★ 14.6K↓ 29.3K/mes19 sept 2026
MPL-2.019 sept 2026 · métricas 2.10.0
Packagist
89Excelenteíndice de salud
Spomky-Labs/otphp
:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
PHP★ 1489↓ 1.8M/mes9 sept 2026
MIT9 sept 2026 · métricas 2.10.0
npm
89Excelenteíndice de salud
yeojz/otplib
One Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2292↓ 51.3M/mes17 sept 2026
MIT17 sept 2026 · métricas 2.10.0
npm
88Excelenteíndice de salud
authup/authup
Self-hosted authentication & authorization system (IAM: OAuth2 & OpenID Connect provider with realms, RBAC & ABAC policies, MFA (TOTP, passkeys, email OTP), identity federation (OIDC, LDAP) and session management.
TypeScript · Vue★ 40↓ 13.4K/mes13 sept 2026
AGPL-3.013 sept 2026 · métricas 2.10.0
Packagist
86Excelenteíndice de salud
antonioribeiro/google2fa
A One Time Password Authentication package, compatible with Google Authenticator.
PHP★ 2007↓ 6.9M/mes27 ago 2026
MIT27 ago 2026 · métricas 2.10.0
npm
86Excelenteíndice de salud
hectorm/otpauth
One Time Password (HOTP/TOTP) library for Node.js, Deno, Bun and browsers.
JavaScript★ 1484↓ 12M/mes11 oct 2026
MIT11 oct 2026 · métricas 2.10.0
NuGet
83Excelenteíndice de salud
WeihanLi/WeihanLi.Common
common tools, methods, extension methods, etc... .net 常用工具类,公共方法,常用扩展方法等,基础类库
C#★ 2439 sept 2026
Apache-2.09 sept 2026 · métricas 2.10.0
PyPI
83Excelenteíndice de salud
scito/extract_otp_secrets
Extract one time password (OTP) secrets from QR codes exported by two-factor authentication (2FA) apps such as "Google Authenticator". The exported QR codes from authentication apps can be captured by camera, read from images, or read from text files. The secrets can be exported to JSON or CSV, or printed as QR codes to console.
Python · Shell★ 166020 sept 2026
GPL-3.020 sept 2026 · métricas 2.10.0
Packagist · npm
83Excelenteíndice de salud
silverstripe/silverstripe-totp-authenticator
Provides a TOTP-based authentication method for the Silverstripe MFA module.
JavaScript · PHP★ 8↓ 6593/mes12 sept 2026
BSD-3-Clause12 sept 2026 · métricas 2.10.0
Packagist · PyPI
81Excelenteíndice de salud
infocyph/OTP
Simple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/mes7 sept 2026
MIT7 sept 2026 · métricas 2.10.0
Go
80Excelenteíndice de salud
Luzifer/nginx-sso
SSO authentication provider for the auth_request nginx module
Go★ 30418 oct 2026
Apache-2.018 oct 2026 · métricas 2.10.0
PyPI
78Buenoíndice de salud
ZYLVEXT/litestar-auth
Fail-closed human and workload authentication for Python and Litestar: opaque sessions, mTLS, DPoP, SPIFFE, webhooks, and HTTP signatures.
Python★ 3↓ 2701/mes23 ago 2026
MIT23 ago 2026 · métricas 2.10.0
npm
78Buenoíndice de salud
authsignal/authsignal-browser
Authsignal Web SDK for authenticating with passkeys, email OTP, SMS OTP and authenticator app (TOTP)
TypeScript★ 8↓ 37.6K/mes18 sept 2026
MIT18 sept 2026 · métricas 2.10.0
npm · Maven
77Buenoíndice de salud
authsignal/react-native-authsignal
Authsignal React Native SDK for authenticating with passkeys, push, email OTP, SMS OTP and authenticator app (TOTP)
TypeScript · Kotlin · Swift★ 5↓ 26.9K/mes15 sept 2026
MIT15 sept 2026 · métricas 2.10.0
crates.io · PyPI
75Buenoíndice de salud
replydev/cotp
Encrypted, command-line TOTP/HOTP authenticator app with import functionality.
Rust★ 385↓ 109/mes18 sept 2026
GPL-3.018 sept 2026 · métricas 2.10.0
npm
71Buenoíndice de salud
DavideCarvalho/adonis-agora-authkit
AuthKit — AdonisJS OIDC Authorization Server kit + OIDC client + React helpers (@dudousxd/adonis-authkit-*)
TypeScript · MDX★ 5↓ 17.5K/mes18 sept 2026
MIT18 sept 2026 · métricas 2.10.0
npm
69Buenoíndice de salud
askrjs/askr-auth
Shared authentication contracts and request authentication for Askr.
TypeScript★ 1↓ 3065/mes16 sept 2026
Apache-2.016 sept 2026 · métricas 2.10.0
Go
67Buenoíndice de salud
JLugagne/egauth
Composable, non-opinionated authentication toolkit for Go — import the modules you need (identity, tokens/JWT, sessions, passkeys, OAuth/OIDC, MFA, OTP) and wire them with DI. Secure-by-default, no framework.
Go★ 016 sept 2026
MIT16 sept 2026 · métricas 2.10.0
—
67Buenoíndice de salud
paolostivanin/OTPClient
A secure, easy-to-use TOTP/HOTP client written in C with a GTK4/libadwaita interface.
C★ 55810 sept 2026
GPL-3.010 sept 2026 · métricas 2.10.0
npm
65Buenoíndice de salud
paulmillr/micro-key-producer
Produces secure keys and passwords. SSH, PGP, OTP, TOR, X509, OTP, SLIP10
TypeScript★ 81↓ 385.9K/mes4 oct 2026
MIT4 oct 2026 · métricas 2.10.0
npm
65Buenoíndice de salud
stacksjs/ts-auth
One-Time Passwords, WebAuthn, and more. Fully typed.
TypeScript★ 2↓ 36.9K/mes18 sept 2026
MIT18 sept 2026 · métricas 2.10.0
crates.io
63Moderadoíndice de salud
constantoine/totp-rs
RFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/mes17 sept 2026
MIT17 sept 2026 · métricas 2.10.0
PyPI
63Moderadoíndice de salud
usestapel/stapel-auth
Full-featured authentication Django app — JWT, passkeys, TOTP, QR, OAuth, SSO, magic link
Python★ 0↓ 4163/mes6 sept 2026
MIT6 sept 2026 · métricas 2.10.0
Packagist
62Moderadoíndice de salud
remotemerge/totp-php
Lightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3462/mes19 sept 2026
MIT19 sept 2026 · métricas 2.10.0
Packagist · npm
57Moderadoíndice de salud
gabrielesbaiz/nova-two-factor
Two-factor authentication for Laravel Nova 5: TOTP, passkeys, email codes, enforcement policies and step-up re-auth.
PHP★ 2↓ 2365/mes9 oct 2026
MIT9 oct 2026 · métricas 2.10.0
Packagist
56Moderadoíndice de salud
MincDev/php-otpauth
A lightweight PHP library for generating and validating TOTP authentication codes and QR codes compatible with Google Authenticator, Microsoft Authenticator, Authy, 1Password, Bitwarden, and other RFC 6238 authenticator apps.
PHP★ 5↓ 4473/mes20 oct 2026
MIT20 oct 2026 · métricas 2.10.0
PyPI
56Moderadoíndice de salud
pyauth/pyotp
Python One-Time Password Library
Python★ 3334↓ 42.2M/mes27 ago 2026
Licencia propia27 ago 2026 · métricas 2.10.0
npm
54Moderadoíndice de salud
NodeBB/nodebb-plugin-2factor
Two-Factor Authentication for NodeBB
JavaScript · Go Template★ 1322 oct 2026
MIT22 oct 2026 · métricas 2.10.0
Go · npm
54Moderadoíndice de salud
Sammy-T/avda
A desktop app for generating and viewing one-time passwords from Aegis Authenticator backups.
Svelte · NSIS · JavaScript★ 6421 oct 2026
GPL-3.021 oct 2026 · métricas 2.10.0