Go · npm100Exceptionalhealth index

authelia/autheliaThe Single Sign-On Multi-Factor portal for web apps. OpenID Certified™ and Post-Quantum Cryptography Ready.
Go · TypeScript★ 29KSep 16, 2026
npm96Exceptionalhealth index

logto-io/logto🧑🚀 Authentication and authorization infrastructure for SaaS and AI apps, built on OIDC and OAuth 2.1 with multi-tenancy, SSO, and RBAC.
TypeScript★ 14.6K↓ 29.3K/moSep 19, 2026
Packagist89Excellenthealth index

Spomky-Labs/otphp:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
PHP★ 1,489↓ 1.8M/moSep 9, 2026
npm89Excellenthealth index

yeojz/otplibOne Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2,292↓ 51.3M/moSep 17, 2026
npm88Excellenthealth index

authup/authupSelf-hosted authentication & authorization system (IAM: OAuth2 & OpenID Connect provider with realms, RBAC & ABAC policies, MFA (TOTP, passkeys, email OTP), identity federation (OIDC, LDAP) and session management.
TypeScript · Vue★ 40↓ 13.4K/moSep 13, 2026
Packagist86Excellenthealth index
PHP★ 2,007↓ 6.9M/moAug 27, 2026
npm86Excellenthealth index

hectorm/otpauthOne Time Password (HOTP/TOTP) library for Node.js, Deno, Bun and browsers.
JavaScript★ 1,484↓ 12M/moOct 11, 2026
NuGet83Excellenthealth index
C#★ 243Sep 9, 2026
PyPI83Excellenthealth index

scito/extract_otp_secretsExtract one time password (OTP) secrets from QR codes exported by two-factor authentication (2FA) apps such as "Google Authenticator". The exported QR codes from authentication apps can be captured by camera, read from images, or read from text files. The secrets can be exported to JSON or CSV, or printed as QR codes to console.
Python · Shell★ 1,660Sep 20, 2026
Packagist · npm83Excellenthealth index
JavaScript · PHP★ 8↓ 6,593/moSep 12, 2026
Packagist · PyPI81Excellenthealth index

infocyph/OTPSimple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/moSep 7, 2026
Go80Excellenthealth index
Go★ 304Oct 18, 2026

ZYLVEXT/litestar-authFail-closed human and workload authentication for Python and Litestar: opaque sessions, mTLS, DPoP, SPIFFE, webhooks, and HTTP signatures.
Python★ 3↓ 2,701/moAug 23, 2026
TypeScript★ 8↓ 37.6K/moSep 18, 2026
npm · Maven77Goodhealth index
TypeScript · Kotlin · Swift★ 5↓ 26.9K/moSep 15, 2026
crates.io · PyPI75Goodhealth index

replydev/cotpEncrypted, command-line TOTP/HOTP authenticator app with import functionality.
Rust★ 385↓ 109/moSep 18, 2026
TypeScript · MDX★ 5↓ 17.5K/moSep 18, 2026

askrjs/askr-authShared authentication contracts and request authentication for Askr.
TypeScript★ 1↓ 3,065/moSep 16, 2026

JLugagne/egauthComposable, non-opinionated authentication toolkit for Go — import the modules you need (identity, tokens/JWT, sessions, passkeys, OAuth/OIDC, MFA, OTP) and wire them with DI. Secure-by-default, no framework.
Go★ 0Sep 16, 2026
C★ 558Sep 10, 2026
TypeScript★ 81↓ 385.9K/moOct 4, 2026
TypeScript★ 2↓ 36.9K/moSep 18, 2026
crates.io63Moderatehealth index

constantoine/totp-rsRFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/moSep 17, 2026
PyPI63Moderatehealth index

usestapel/stapel-authFull-featured authentication Django app — JWT, passkeys, TOTP, QR, OAuth, SSO, magic link
Python★ 0↓ 4,163/moSep 6, 2026
Packagist62Moderatehealth index

remotemerge/totp-phpLightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3,462/moSep 19, 2026
Packagist · npm57Moderatehealth index

gabrielesbaiz/nova-two-factorTwo-factor authentication for Laravel Nova 5: TOTP, passkeys, email codes, enforcement policies and step-up re-auth.
PHP★ 2↓ 2,365/moOct 9, 2026
Packagist56Moderatehealth index

MincDev/php-otpauthA lightweight PHP library for generating and validating TOTP authentication codes and QR codes compatible with Google Authenticator, Microsoft Authenticator, Authy, 1Password, Bitwarden, and other RFC 6238 authenticator apps.
PHP★ 5↓ 4,473/moOct 20, 2026
PyPI56Moderatehealth index
Python★ 3,334↓ 42.2M/moAug 27, 2026
npm54Moderatehealth index
JavaScript · Go Template★ 13Oct 22, 2026
Go · npm54Moderatehealth index

Sammy-T/avdaA desktop app for generating and viewing one-time passwords from Aegis Authenticator backups.
Svelte · NSIS · JavaScript★ 64Oct 21, 2026