All tags
Catalogue tag

#url

Every repository in the public record carrying this tag — from its GitHub topics or the keywords its package registries publish. Health is measured under the same versioned methodology as the rest of the record.

176 records
Tagged “url”Ranked by health index
npm
34At Riskhealth index
sindresorhus/got
🌐 Human-friendly and powerful HTTP request library for Node.js
TypeScript★ 14.9K↓ 145M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
32At Riskhealth index
lquixada/cross-fetch
Universal WHATWG Fetch API for Node, Browsers and React Native.
JavaScript · TypeScript★ 1,695↓ 142M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
31At Riskhealth index
helpers/handlebars-helpers
188 handlebars helpers in ~20 categories. Can be used with Assemble, Ghost, YUI, express.js etc.
JavaScript★ 2,269↓ 412.2K/moSep 18, 2026
MITSep 18, 2026 · metrics 2.10.0
crates.io
31At Riskhealth index
jedisct1/rust-uri-encode
encodeURI() and encodeURIComponent() for Rust.
Rust★ 3↓ 2,637/moSep 25, 2026
No licenseSep 25, 2026 · metrics 2.10.0
npm
31At Riskhealth index
unshiftio/url-parse
Small footprint URL parser that works seamlessly across Node.js and browser environments.
JavaScript★ 1,034↓ 149M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
29At Riskhealth index
JowayYoung/bruce
🔥 Bruce FEES 一套多功能前端工程化多包管理实践方案 📦
TypeScript · JavaScript★ 71↓ 4,091/moSep 18, 2026
MITSep 18, 2026 · metrics 2.10.0
npm
29At Riskhealth index
sindresorhus/base62
Encode & decode strings, bytes, and integers to Base62
JavaScript★ 94↓ 11.7M/moSep 23, 2026
MITSep 23, 2026 · metrics 2.10.0
npm · Packagist
28At Riskhealth index
medialize/URI.js
Javascript URL mutation library
JavaScript · HTML★ 6,227↓ 23.5M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
27At Riskhealth index
defunctzombie/node-url
node.js core url module as a module
JavaScript★ 375↓ 88.9M/moSep 15, 2026
MITSep 15, 2026 · metrics 2.10.0
npm
26At Riskhealth index
jridgewell/resolve-uri
Resolve a URI relative to an optional base URI
JavaScript★ 11↓ 706M/moSep 16, 2026
MITSep 16, 2026 · metrics 2.10.0
npm
26At Riskhealth index
mathiasbynens/punycode.js
A robust Punycode converter that fully complies to RFC 3492 and RFC 5891.
JavaScript★ 1,692↓ 772M/moSep 16, 2026
MITSep 16, 2026 · metrics 2.10.0
npm
26At Riskhealth index
unshiftio/requires-port
Check if a protocol requires a certain port number to be added to an URL.
JavaScript★ 11↓ 183M/moSep 16, 2026
MITSep 16, 2026 · metrics 2.10.0
npm
24At Riskhealth index
elara-bots/npm
No repository description published.
HTML · TypeScript · JavaScript★ 4↓ 146/moSep 13, 2026
No licenseSep 13, 2026 · metrics 2.10.0
crates.io
24At Riskhealth index
kornelski/rust_urlencoding
A Rust library for doing URL percentage encoding.
Rust★ 77↓ 19.7M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
23At Riskhealth index
bholloway/resolve-url-loader
Webpack loader that resolves relative paths in url() statements based on the original source file
JavaScript★ 558↓ 34.9M/moSep 23, 2026
No licenseSep 23, 2026 · metrics 2.10.0
npm · RubyGems
23At Riskhealth index
pid/speakingurl
Generate a slug – transliteration with a lot of options
JavaScript★ 1,116↓ 17.8M/moSep 23, 2026
BSD-3-ClauseSep 23, 2026 · metrics 2.10.0
npm
22At Riskhealth index
stevenvachon/relateurl
Create a relative URL with options to minify.
JavaScript★ 56↓ 73M/moOct 21, 2026
MITOct 21, 2026 · metrics 2.10.0
npm
21At Riskhealth index
mongolab/mongodb-uri-node
No repository description published.
JavaScript★ 39↓ 1.3M/moSep 9, 2026
MITSep 9, 2026 · metrics 2.10.0
npm
21At Riskhealth index
open-element/url-pattern-list
Efficiently match URLs against a collection of URLPatterns
TypeScript★ 0↓ 5,954/moOct 19, 2026
MITOct 19, 2026 · metrics 2.10.0
npm
20At Riskhealth index
boennemann/nerf-dart
No repository description published.
JavaScript★ 6↓ 10.5M/moSep 23, 2026
No licenseSep 23, 2026 · metrics 2.10.0
PyPI
20At Riskhealth index
sangoma/ursine
The most bearable SIP URI library
Python★ 6↓ 240/moSep 13, 2026
Apache-2.0Sep 13, 2026 · metrics 2.10.0
npm
19Criticalhealth index
JavaScript★ 4,321↓ 112M/moSep 17, 2026
MITSep 17, 2026 · metrics 2.10.0
npm
12Criticalhealth index
lydell/resolve-url
[DEPRECATED] Like Node.js’ `path.resolve`/`url.resolve` for the browser.
JavaScript★ 53↓ 38M/moSep 15, 2026
MITSep 15, 2026 · metrics 2.10.0
PyPI
11Criticalhealth index
dgerber/rfc3987
Parsing and validation of URIs (RFC 3896) and IRIs (RFC 3987)
Python★ 46↓ 3.1M/moSep 10, 2026
GPL-3.0Sep 10, 2026 · metrics 2.10.0
npm
11Criticalhealth index
lydell/urix
[DEPRECATED] Makes Windows-style paths more unix and URI friendly.
JavaScript★ 64↓ 37.7M/moSep 15, 2026
MITSep 15, 2026 · metrics 2.10.0
Packagist
7Criticalhealth index
Guzzle3/parser
[Guzzle 3] [READ-ONLY] Subtree split of the Guzzle\Parser component. Provides parsing interfaces for Cookies, HTTP messages, and URI Templates
PHP★ 21↓ 46.2K/moSep 13, 2026
No licenseSep 13, 2026 · metrics 2.10.0