NuGet91Excellenthealth index
C#★ 49Oct 21, 2026
Packagist89Excellenthealth index

Spomky-Labs/otphp:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
PHP★ 1,489↓ 1.8M/moSep 9, 2026
npm89Excellenthealth index

yeojz/otplibOne Time Password (OTP) / 2FA for Node.js and Browser - Supports HOTP, TOTP and Google Authenticator
TypeScript★ 2,292↓ 51.3M/moSep 17, 2026
Packagist86Excellenthealth index
PHP★ 2,007↓ 6.9M/moAug 27, 2026
npm86Excellenthealth index

hectorm/otpauthOne Time Password (HOTP/TOTP) library for Node.js, Deno, Bun and browsers.
JavaScript★ 1,484↓ 12M/moOct 11, 2026
Hex · npm84Excellenthealth index

DROOdotFOO/raxolraxol.io - one Elixir module, every surface. The terminal for your Gundam.
Elixir★ 79↓ 238/moOct 1, 2026
PyPI83Excellenthealth index

scito/extract_otp_secretsExtract one time password (OTP) secrets from QR codes exported by two-factor authentication (2FA) apps such as "Google Authenticator". The exported QR codes from authentication apps can be captured by camera, read from images, or read from text files. The secrets can be exported to JSON or CSV, or printed as QR codes to console.
Python · Shell★ 1,660Sep 20, 2026
npm83Excellenthealth index
TypeScript★ 46↓ 43.3K/moOct 20, 2026
Packagist · PyPI81Excellenthealth index

infocyph/OTPSimple but Secure Generic OTP, OCRA (RFC6287), TOTP (RFC6238) & HOTP (RFC4226) solution!
PHP★ 17↓ 10.3K/moSep 7, 2026
NuGet · npm80Excellenthealth index

EvotecIT/CodeGlyphXCodeGlyphX is a fast, dependency-free toolkit for QR codes and barcodes, with robust decoding and a minimal API. It targets modern .NET as well as legacy .NET Framework, and includes renderers, payload helpers, and WPF controls.
C#★ 43Oct 8, 2026
npm80Excellenthealth index
JavaScript · TypeScript★ 3,260↓ 118M/moSep 17, 2026
C++ · Erlang★ 605↓ 41.6K/moSep 9, 2026
Packagist77Goodhealth index
PHP★ 182↓ 118.4K/moSep 12, 2026
Elixir · Erlang★ 103↓ 198.4K/moSep 9, 2026
Gleam★ 874↓ 52.5K/moSep 9, 2026
TypeScript · MDX★ 3↓ 4,547/moSep 16, 2026
Elixir★ 36↓ 2,338/moSep 24, 2026
C★ 558Sep 10, 2026
Go · HTML★ 61Sep 13, 2026
TypeScript★ 81↓ 385.9K/moOct 4, 2026
TypeScript★ 30↓ 19.8K/moSep 23, 2026
Erlang★ 49↓ 172.9K/moSep 9, 2026
TypeScript★ 2↓ 36.9K/moSep 18, 2026
crates.io63Moderatehealth index

constantoine/totp-rsRFC-compliant TOTP implementation with ease of use as a goal and additionnal QoL features.
Rust★ 271↓ 973K/moSep 17, 2026
Hex · npm63Moderatehealth index

elixir-volt/quickbeamJavaScript runtime for the BEAM — Web APIs backed by OTP, native DOM, and a built-in TypeScript toolchain.
C · Elixir★ 420↓ 5,092/moSep 9, 2026
Hex62Moderatehealth index
Elixir★ 83↓ 1,664/moSep 9, 2026
Hex62Moderatehealth index
Elixir · Python★ 96↓ 3,365/moSep 18, 2026
Packagist62Moderatehealth index

remotemerge/totp-phpLightweight, fast, and secure TOTP (2FA) authentication library for PHP — battle tested, dependency free, and ready for enterprise integration.
PHP★ 25↓ 3,462/moSep 19, 2026
Hex60Moderatehealth index

nshkrdotcom/claude_agent_sdkAn Elixir SDK for Claude Code - provides programmatic access to Claude Code CLI with streaming message processing
Elixir★ 36Sep 9, 2026
Packagist60Moderatehealth index

tzsk/otpGenerate OTP with expiry for PHP without using Database
PHP★ 242↓ 10.6K/moSep 12, 2026